PDA

View Full Version : How do I install ghost armor? WITH PICS




mr jnvii
Apr 14, 2011, 09:38 AM
The directions say to immerse the thing into a 12oz cup with 6 drops of dishwashing soap, but every video guide on people installing it shows them using a small spray bottle.

What is the best way here? I have a small spray bottle to use, but how much soap would I put in it then?

I'm a little confused as to the best method here. If I should use a spray bottle, can someone tell me how much soap to put in?(the size is like 1-2oz)

Thanks.



Hoyasaxa
Apr 14, 2011, 11:33 AM
I installed one from Best Skins Ever a few days ago, but the concept is the same.

Use the spray bottle. It will provide the right amount of water, and also is handy if you need to respray because the fit isn't right the first or second time and you need to pull off the skin and start over.

As for soap, you could probably do it without any, but I put about 2 drops of baby shampoo into my solution and it was fine. The more you use, the bigger chance of a bubbly solution, which is no good.

mr jnvii
Apr 14, 2011, 02:39 PM
Got my iPad a few hours ago and immediately put the ghost armor back protection on. I used the spray with 1 drop of soap in a 2oz spray bottle. Went on perfectly (well there was a blue dust thingy at the corner, so easy fix)

The fit isn't perfect though. The hole aligns perfectly with the camera, but the cut near the audio jack is off.

BadMoon
Apr 15, 2011, 06:42 AM
Got my iPad a few hours ago and immediately put the ghost armor back protection on. I used the spray with 1 drop of soap in a 2oz spray bottle. Went on perfectly (well there was a blue dust thingy at the corner, so easy fix)

The fit isn't perfect though. The hole aligns perfectly with the camera, but the cut near the audio jack is off.

You installed it wrong. It all lines up perfectly. If you just used the camera hole to align everything that is why it's not lined up. You can request a replacement and re-install it. I know because I made the same mistake. :D

mr jnvii
Apr 15, 2011, 10:06 AM
You installed it wrong. It all lines up perfectly. If you just used the camera hole to align everything that is why it's not lined up. You can request a replacement and re-install it. I know because I made the same mistake. :D

Really? haha. It's near perfect except the part near the audio jack isn't centered. It isn't covering anything or making it difficult to put my headphones on though. There also was like .5 mm of film over the charging port, so I took a scalpel and cut it off. Can't tell though. Those little jag marks on the charging port are actually from the cable that goes in there. It's a bit of a tight fit, which I don't really like. I dunno know if it's the cable or it's the iPad though.
But, since there are no air bubbles or dust (at least noticeable ones) there is no way I'll replace it and risk dicking up the new one :D

The directions really don't say how to align it though. I assumed going by the camera was enough. Oh well :rolleyes:

Here are some pics of it. You honestly cannot even tell it is there. It has a little grip to it, but doesn't feel like it's a skin, just part of the iPad

http://i718.photobucket.com/albums/ww188/adeafboy07/DSCN0285.jpg
http://i718.photobucket.com/albums/ww188/adeafboy07/DSCN0286.jpg
http://i718.photobucket.com/albums/ww188/adeafboy07/DSCN0287.jpg
http://i718.photobucket.com/albums/ww188/adeafboy07/DSCN0288.jpg

BadMoon
Apr 15, 2011, 04:50 PM
Yep! Made the same mistake. Had a new one sent and it looks perfect.

http://i221.photobucket.com/albums/dd2/badmoon2/DSC_0006.jpg

http://i221.photobucket.com/albums/dd2/badmoon2/DSC_0008.jpg

http://i221.photobucket.com/albums/dd2/badmoon2/DSC_0007.jpg

http://i221.photobucket.com/albums/dd2/badmoon2/DSC_0010.jpg

http://i221.photobucket.com/albums/dd2/badmoon2/DSC_0011.jpg

http://i221.photobucket.com/albums/dd2/badmoon2/DSC_0044-1.jpg

http://i221.photobucket.com/albums/dd2/badmoon2/DSC_0056-1.jpg

jps1012
Dec 31, 2012, 10:44 AM
Ugh i want one for my iPad but nervous to install it. Is it harder then installing a screen protector?