PDA

View Full Version : Mac App Store Binary Rejection Question




Avizzv92
Apr 15, 2011, 11:06 PM
I had to change my application's name, it led to a rejection; after changing the name and the respective build settings I submitted the new binary to the Mac App Store with Xcode 4. Xcode uploads it without problem but a few minutes later the binary will be rejected with this message:

Unsupported Architecture - Application executables may support either or both of the Intel architectures:

i386 (32-bit) x86_64 (64-bit)

Other architectures may not be included in submitted binaries. Confirm that your Xcode project's build settings include those architectures and no others.

I triple checked the build settings, and they were the same ones (except for the Product Name) as the initial binary that worked. Would anyone have insight as to what may be causing this problem? I checked the Target's "Architectures" and "Valid Architectures" settings and they are correct. I ran lipo -info on the Unix Excutable File and I got x86_64.

By an off chance, would the fact that my app ends in an '!' cause problems? i.e."MyApp!.app"

Does Apple require you use the latest Xcode version? I have 4.0.0 not 4.0.2.