PDA

View Full Version : Screen Spanning Stopped Working in iBook


18thTomorrow
Mar 6, 2005, 08:59 PM
Hello There,
I've successfully used Screen Spanning Doctor to allow my iBook to span with an external monitor...It's worked great for like 7 months now. But all of a sudden today it just...quit. Like I was typing a letter and all of a sudden my screen blanked and then started mirroring instead of spanning. I've tried disabling/enabling SSD a few times but to no avail. Anyone else have this problem or suggestions on how to fix it? I'm really handicapped without it! I loved my double workspace!

whocares
Mar 7, 2005, 03:59 AM
Have you tried zapping the PRAM and then re-enabling SSD?

18thTomorrow
Mar 7, 2005, 05:53 PM
Yes, after I posted I read the SSD readme and realized that zapping the PRAM might help. It did, and I was able to enable SSD, but it quit again this afternoon--while I was away from my computer at some point. I have zapped the PRAM several times now and run SSD 3 or 4 times but to no avail. I haven't been doing anything different...I just wonder what causes this, all of a sudden after it's worked for half a year...? :confused:

18thTomorrow
Mar 7, 2005, 07:02 PM
On further contemplation I wonder if another problem may have something to do with it. A software problem, rather than a firmware problem. For a couple weeks now, my desktop wallpaper has been acting up. For example -- I'll boot it up and it won't be the wallpaper I've currently chosen, but one from two or three wallpapers ago. Or I'll connect an external monitor and that external wallpaper won't be the external wallpaper it was last time. Or there's no wallpaper at all. When I try to change the wallpaper either by right-clicking on the desktop or going through system preferences>desktop & screensaver, System Preferences unexpectedly quits. Is there some preference file or something that might have gotten scrambled at some point, just from lots of switching of monitors and wallpapers on the fly? Something I can reinstall or trash to make it reset?
thanks everyone

Bear
Mar 7, 2005, 07:39 PM
That could be a preferences file. Or it could be you need to repair permissions.
If neither of those work, try applying the combo update as that seems to fix some issues caused by the mini patch updates Apple has released.

Mechcozmo
Mar 7, 2005, 07:58 PM
Have you tried repairing permissions?
Have you tried running Preferential Treatment? (http://homepage.mac.com/jonn8/as/)?

18thTomorrow
Mar 8, 2005, 07:11 AM
I'm back in business! I believe it was caused the desktops preference file being corrupted. After trashing that and a few others, zapping PRAM, running fsck, and repairing permissions for good measure, everything's working again. Thanks people!