PDA

View Full Version : Unresponsive keyboard/trackpad/power button




Nny0
May 1, 2011, 09:26 PM
Hello you cool, cool cats :cool:

So about a month ago I upgrade from Leopard to Snow Leopard (brrrr so cold)

About a week after that, I started having problems where my keyboard and trackpad would be unresponsive for about a minute. This would happen every few weeks.

At one point, it wasn't just a minute, but about 10-20 minutes. :( But other than that, it'd just be for about a minute and would work again.

Flash forward to today. It happened again, and it was one that still wasn't being responsive after 5 minutes. So, since I've been into my macbook a few times (replace optical drive and LCD), I figured I'd open it up to make sure the ribbon was all the way plugged in.

Well, it was all the way plugged in; Tried unplugging it and plugging it back in. Except now it won't turn on at all. :((((

So I was like "Yo google, my man, help me out!" And Google was all like "I gotcha, I gotcha" but google didn't got me. It seems unresponsive keyboard and trackpad is a common problem. One of the issues being a ribbon under the battery (Pressing it down did nothing) and resetting pram/smc (Except my keyboard doesn't work, so how do I do that?).

In order to make sure it was my keyboard that was broken and not the logic board, I short circuited it to power up (Which I found out how to do on this forum - If you read this wesli_1 I <3 you baby!) and that worked fine and I was all like ok!

Then I was like ha! I can reset the smc this way I think! So I held down the solder pads for a few seconds to reset the smc and was like plz baby plz! But still not working.

So yeah, I certainly assume problem = the upper case keyboard thingy and to replace it. But since I've read a lot about people with unresponsive keyboard/trackpad that buying a new keyboard did nothing to remedy the issue, I figured I'd check here first to make sure everyones like "ya bro that's the issue, now order one and forget that **** and let's get wasted!" and I'd be like "I don't drink but thanks for the help!"

It's a 2008 Macbook 4,1 if it matters.



fords4life
Jun 21, 2012, 11:48 PM
Sorry to revive such an old thread but this describes the problem I am having to a t. Any chance you ever figured out what the problem was?