PDA

View Full Version : windows/os x/linksys wireless networking problem


roraz
Mar 10, 2005, 04:55 PM
my family has recently purchased some wireless enabled computers and laptops.

3 windows computers (1 computer cabled to the gateway, the other two wireless enabled) - 1 wireless g4 powerbook (just got today)

I thought id share the wealth by allowing them access to my broadband and files. I bought a linksys wireless adsl modem gateway, I connected the gateway to my computer via ethernet cable and plugged the gateway to the telephone line.

I followed the instructions and set up my isp details in the browser. That was it..

the other 2 windows computers and the powerbook detected the wireless network and all the wireless computers have access to the internet via my broadband connection.

however im not sure how to access the other computer files??

I looked at this - http://forums.macrumors.com/showthread.php?t=54704

but i got a bit confused, plus i figured I needed to sort out the file sharing between all the windows computers first before trying to do it between a windows and a Mac :D

All my computers ahve their own names and are in the same workgroup but apart from that im not really sure what to do and everything I ve looked at on google was confusing (linsys manual/support wasn't any help either)

any help/advice would be appreciated :confused:

jim.
Mar 10, 2005, 06:38 PM
First off, are you encrypting your network? WPA and WEP will break filesharing for some reason. If not then let's keep going.

I assume that you have done the network setup on the Windows machines? And they aren't running the firewall as is default in SP2 (if you have that)? I've found that even if you open the smb port, filesharing won't always work with that firewall on. I know it should work but my dumb self can't get it right apparently.

If you've done all the stuff to this point, I'm going to have to start looking for more details before I get back to you. It's been a long time since I have troubleshot smb sharing.

With the mac you should just have to start windows sharing, and it should work decently. You could delve into the /etc/samba/smb.conf and tweak it, but you shouldn't have to.

Jim

roraz
Mar 10, 2005, 08:21 PM
right something happened (i think after i turned off all the firewalls on all the computers)

the computers that were on - my main one (connected by cable to the gateway), my powerbook and the computer downstairs

suddenly my powerbook folders and the downstairs cpu shared folders appeared in my network on my main computer, in the workgroup the powerbook appeared and so did the downstairs computer

on the mac, its folders appeared on the network as well as the downstairs computers shared folders

on the downstairs cpu all the folders mentioned above appeared, and in workgroups its own computer appeared, as well as the mac

however

the main computer did not appear on the downstairs computers workgroup list, nor did it appear in the powerbooks network listings (also mention that while the downstairs computers own name appeared in its workgroup listings, the main computer for some reason doesn't appear in its own listing for workgroups)

if you can understand all that, basically im saying that the main 'cabled' computer for some reason isn't showing up on any of the computers network listings (even though the other computers are appearing on it)

Ive checked, and its firewall is off as well. Im not sure why it isn't appearing in the workgroup listings :confused:

jim.
Mar 10, 2005, 08:27 PM
Sounds like sharing isn't on. Stupid question, but you did do the network setup on that computer, right?

Otherwise it could be that the wireless and wired network aren't bridged correctly. This would be a router issue if it is true, and I have no idea how to fix it. We will have to hand the torch to a more experienced person.

Can you ping your main computer from your powerbook? If you can then the networks are bridged and sharing just isn't active. If not then something us up with your router.

Jim

roraz
Mar 10, 2005, 08:36 PM
what do i have to type in the powerbook (im guessing in utilities) to ping my main computer?

i don't think there is a problem with the router, the reason being i finally managed to do this - http://forums.macrumors.com/showthread.php?t=54704

i got my main computers shared mp3 folder on my powerbook, so that means the connection between them is alright. But for some reason the main computer doesn't want to register in the workgroup listings or on the powerbooks networks?? while i could use the above method to access stuff off the main computer through the powerbook, i still can't access the main computer from the other windows computers in the house....

edit: worked how to ping the main computer from the powerbook, heres the results:

Ping has started ...

PING 192.168.1.100 (192.168.1.100): 56 data bytes
64 bytes from 192.168.1.100: icmp_seq=0 ttl=128 time=2.254 ms
64 bytes from 192.168.1.100: icmp_seq=1 ttl=128 time=1.154 ms
64 bytes from 192.168.1.100: icmp_seq=2 ttl=128 time=1.159 ms
64 bytes from 192.168.1.100: icmp_seq=3 ttl=128 time=1.198 ms
64 bytes from 192.168.1.100: icmp_seq=4 ttl=128 time=1.155 ms
64 bytes from 192.168.1.100: icmp_seq=5 ttl=128 time=1.142 ms
64 bytes from 192.168.1.100: icmp_seq=6 ttl=128 time=1.144 ms
64 bytes from 192.168.1.100: icmp_seq=7 ttl=128 time=1.173 ms
64 bytes from 192.168.1.100: icmp_seq=8 ttl=128 time=1.148 ms
64 bytes from 192.168.1.100: icmp_seq=9 ttl=128 time=1.156 ms

--- 192.168.1.100 ping statistics ---
10 packets transmitted, 10 packets received, 0% packet loss
round-trip min/avg/max = 1.142/1.268/2.254 ms


is this normal?

jim.
Mar 10, 2005, 09:52 PM
Yep, your networks are bridged correctly. So you can access a share from your main computer? Are you just connecting directly by IP address? I'm guessing it is something with the smb protocol streaming from network to network. Now we are getting way out of my league, so I may not be much help anymore.

Jim

roraz
Mar 12, 2005, 08:40 PM
all my computers on the network are showing in the workgroup listing except the cabled system (my main computer).

the others are all connected to each other just fine, and can access each other

i know theres not a connection problem as i can ping the main machine from all the other computers, plus access the net on the machine.

I don't know why the main computer isn't showing up in the workgroup??

its starting to drive me nuts :mad:

Ive run the network wizard/enabled file sharing on the main machine, checked that the main machine was in the workgroup?

Some point today for some fluke reason the main machine turned up in the other computers listings, and I could access its files from them. I don't know what I did (if anything) but it seems to have dissappeared. :(

the other xp machines and the Mac were easy, they just showed up, but the main machine is being a pain in the arse :mad:

Celeron
Mar 13, 2005, 09:52 AM
First off, are you encrypting your network? WPA and WEP will break filesharing for some reason. If not then let's keep going.

I can't believe someone would actually suggest this as being true. WEP and WPA have nothing to do with Windows filesharing and turning either one on (or off) will have no effect what-so-ever on your ability to see and/or share files to other computers.

edesignuk
Mar 13, 2005, 09:58 AM
I can't believe someone would actually suggest this as being true. WEP and WPA have nothing to do with Windows filesharing and turning either one on (or off) will have no effect what-so-ever on your ability to see and/or share files to other computers.
You beat me to it.

Just to reaffirm those comments. Wireless encryption has no impact on file sharing.

I have WPA security on my wirless LAN (which hooks in to my wired LAN) and have no problems at all.

Westside guy
Mar 13, 2005, 02:28 PM
I can't believe someone would actually suggest this as being true. WEP and WPA have nothing to do with Windows filesharing and turning either one on (or off) will have no effect what-so-ever on your ability to see and/or share files to other computers.

You are correct - although you could perhaps have phased this a little less insultingly.