PDA

View Full Version : iPod erasing music, restarting randomly, not adding music, mounting slowly




l0uismustdie
May 10, 2011, 11:27 PM
I have a 5th generation 120GB Classic iPod. Several months ago it started behaving strangely (lagging while changing songs, lagging while scrolling, etc). Upon restarting the iPod I was faced with no music. The next time I plugged my iPod in iTunes said the disk was corrupted and to restore it. When I tried to do the restore iTunes hung for a couple hours. So, I rebooted the iPod into disk mode, used disk utility to erase the partition, unplugged it, restarted it, plugged it in and iTunes recognized it as a formatted iPod and I did the initial setup stuff. After this I ejected the iPod just to make sure it wouldn't crash and become corrupted again (as it had done a couple times prior).

I finally got to the point where I could refill the iPod with my music but the transfer was painfully slow and I had to stop it after several hours to use my computer for something else. I also noticed when mounting the iPod it would take a really long time to mount, if it mounted at all, and would no longer automatically open iTunes as it used to.

To test some things I plugged in my girlfriends iPod which connected instantaneously and was able to add several thousand songs in the time it took to add about 1/7 as many on my iPod.

At this point my iPod restarted itself again and erased all of the songs I had added back onto it.

Currently I have restarted into disk mode, erased, restarted again and during the initial iTunes setup my iTunes has gotten hung on setting up the iPod.

Sorry for the long-wined post but if anyone has any suggestions I would be greatly appreciative.



l0uismustdie
May 12, 2011, 10:22 PM
Well I've tried another pass at restoring:
1. Reboot iPod into disk mode
2. Erase through disk utility
3. Eject from finder and reboot iPod
4. Reconnect and use iTunes to restore iPod
-iPod successfully restores and reboots on it's own
5. Eject and reboot iPod
6. Successfully uploaded about 1000 songs and ejected iPod
7. Plugged iPod back in and iTunes reported a corrupted iPod and suggested restoring the iPod to fix.

If anyone has any ideas about this please let me know. Thanks.