PDA

View Full Version : Sharing a printer


clykins90
Mar 14, 2005, 07:53 AM
OK

I have some PC's (soon to be macs) and a Mac. I have a Lexmark X5150 hooked up to one of the PCs and an HP deskjet 5650 hooked up to the mac. My PCs can print to the Lexmark fine, however, my PC's won't print to the mac and the mac won't print to the Lexmark. How can I fix this? I have the Mac and the PCs networked, but the Mac can only see the PCs (the PCs can't use the mac's files) Its really weird.


BTW, I have an airport express as my router.

grapes911
Mar 14, 2005, 08:16 AM
Not to sound rude, but have you searched first? There are win/mac printing posts everywhere. If you haven't, search first. If none apply to you or don't work, get back to us and let us know what you tried. Someone will be happy to help.

mfacey
Mar 14, 2005, 08:17 AM
I can tell you that doing this is pretty challenging. Frankly its a nightmare.

Here's a link with a fairly non-intuitive guide:
http://members.cox.net/18james/osx_printer_sharing.html
(Sorry, I've read another better one somewhere, but can't find it anymore!)

If that link doesn't help you, try searching on Google for something like "mac windows printer sharing". You'll find some useful and less usefull threads from various forums that way.

And the Apple Support discussion board is always worth a short.

Oh and don't forget searching the Macrumors forums! (thanks to the poster above for that reminder! :p )

I eventually gave up and just decided to make sure that the USB connector of the printer was easily accessible so I could just plug it into the machine I needed to print from. Simple, but very effective.

stevep
Mar 14, 2005, 11:05 AM
On the mac-
Make sure your printer is shared - see the topic in Mac Help. And when you've shared your printer make sure you also turn on Printer Sharing. Shared printers automatically appear in Print dialogs on other computers connected to your local network (your IP subnet).

On the pc-
You've obviously already shared your Lexmark as other pc's can print to it. The problem is that the mac can't see it. Via System Preferences, go to the 'Set up printers...' button in Print Utility, Add printer in the next box, and select Internet Printing Protocol as your printer type. Then type in the ip address of the computer that the printers connected to, and select the Lexmark printer model. I'm assuming that you have a driver file somewhere, maybe already installed (I haven't checked whether your printers are natively supported by OSX but I'm sure you can do that :))

cubist
Mar 16, 2005, 08:32 AM
I have a Tek Phaser 540, shared per the web document, but the Windows 2K PC doesn't see it. I notice lots of people having similar difficulties.

It does no good to say look at other threads when none of those threads have answers either.