PDA

View Full Version : iPod Video 30GB battery issue




joelstitch
May 28, 2011, 09:06 PM
So my iPod stopped working a while ago and from reading around I figured out that it was the battery because it wasn't turning on or doing anything. So I ordered a battery and installed it and it started working just like normal for a few hours. A few hours later that same day I tried to charge the ipod and it wasn't charging or turning on. Is this a known issue or could it be that the battery I ordered was bad?

I bought a second battery and it did the same, it worked for a few hours and then the battery dies while it was on a iPod speaker dock that charges the battery while it plays...I thought maybe it should be the connector for the USB cable, but then I remember that it worked fine when I first connected the batteries. This is driving me crazy, I really don't know what it could be.



Alvi
May 29, 2011, 03:13 AM
I think something might be screwing up your batteries, I'd go to apple

MattA
May 29, 2011, 07:31 AM
It sounds like it's a problem with the charging circuit. Having had problems with 3 batteries sounds a bit fishy to me.

joelstitch
May 30, 2011, 03:04 PM
It sounds like it's a problem with the charging circuit. Having had problems with 3 batteries sounds a bit fishy to me.

How would I fix that?

GreatDrok
May 31, 2011, 01:17 AM
My 80GB is doing the same. From what I can gather the fix is to get a new logic board but they're pretty expensive so I may well just give it up.