PDA

View Full Version : Blue Screen at Startup




kevinoh33
Jun 1, 2011, 07:56 PM
Today my 13" MacBook Pro did one of those automatic update checks and it told me that an update was available. So like usual, I followed through with the update but I did not connect my laptop to a power source. I did this many time before without a power source and updates were always successful. Plus, my battery was over 80% so I didn't think I needed to.

After the installation, I noticed that the little update icon at the dock didn't go away. I tried right clicking it at pressed "force quit", but nothing happened. So then I thought, "It'll go away on it's own when I shut down". But then when I tried to close other applications and Google Chrome it wouldn't close. It wouldn't refresh the page either. I clicked on the little :apple: symbol on the top of the screen and pressed "Shut Down..." but nothing happened. I tried it numerous times but it wouldn't shut down. So then I pressed and held the power button until I forced it to shut down. I turned it back on and everything appeared to be fine, but none of my application such as google chrome or safari would open. I would click the icon and nothing would happen. I also tried shutting it down again but that didn't work either. So once again I forced it to shut down but holding down the power button. This time, when it turned on, the usual Apple logo appeared but then it switched to a blue screen. My cursor was visible but the screen was blue. Then suddenly,my cursor disappeared and a slightly darker blue screen with that wheel symbol (that tells you to wait?) appeared. Then it switched back to the slightly lighter blue screen with my cursor. It kept alternating back and forth but that was all that happened.

I tried repair the disk and disk permissions through the OSX Installation CD. My Windows 7 bootcamp partition was also working so I looked up information on google and tried starting up my OSX partition with safe mode by holding shift at start up. It worked! All my files were still there and that's how I am able to type this thread right now. But my question is, how do I fix my laptop so that it will start up normally without safe mode?

Thanks in advance!