PDA

View Full Version : Klipsch iFi starting to have static, crackle




swingerofbirch
Jun 2, 2011, 11:50 PM
I bought a set of speakers a long time ago (I'm not good at remembering years), but probably greater than 4 years ago, called Klipsch iFi. Neither I nor anyone in my family ever knew anything about sound. We've had small boomboxes and the most basic TVs.

I got these because they were being cleared out at Costco and I got the last box for around $150-200, which as I recall was a big discount.

They have been one of my smartest purchases ever. The sound is wondah-ful. I'm not an audiophile, but I love these.

Anyhow, one day I was playing my music a bit louder than usual on them, but not so loud I thought I would break anything, and I noticed ever since then, if I play them at a medium volume, certain sounds cause a static, crackly sound. It's quite disappointing. I play my music through an Airport Express.

I have unplugged and replugged all of the connections. This actually improved the static/crackling sound. But the crackling sound still comes in at medium volume when certain sounds are played, I think probably sounds with more bass. If I turn up the volume louder, the crackling will invariably play. Some songs don't seem to reproduce the crackling as much as others. Strangely the song which I originally think I may have played too loud was Adele's "Rolling in the Deep," which, when I play it loud, does not induce any static or crackling. I hear it more when I play quieter songs like the Glee version of "Songbird" and the piano notes sound. The song "Treefingers" by Radiohead, which is sort of a deep bass ambient sound song, induces a light constant crackling, so it seems somewhat bass related.

Are there any suggestions? Can speakers like these be repaired? Do you think it was something I did or maybe it's still a bad connection? I always assumed these speakers would work for me forever. I wouldn't even know where to find another set like them; it was wonderful, dumb luck I found them to begin with.

Thanks!