PDA

View Full Version : My iBook's Trackpad! Mercy!


t300
Mar 22, 2005, 10:21 AM
Hello all. I just obtained a 500mhz iBook G3 that is in great condition and running smooth. Right when I got it, I booted it and it was running Jaguar. Right then I noticed the trackpad or button wasn't working at all...I plugged in an external Apple USB mouse, and bang...a moving cursor. I upgraded it to Panther, a complete fresh install, and everything. Currently, it has every update out, I have reset the power management and all. I assume it might be a physical thing and perhaps the cable is loose or not plugged in...If that's the case, anyone have any instructions as to how I would go about checking that? I appreciate it and can't wait to hear from you all!

Edit: Oh, also...In the prefs, there is NO panel for a trackpad like there is on my PB G4. Thanks

P.S.: Besides that, the only other problem is that the latch doesn't catch, it comes down when it get to it, the button presses in and out, but nothing..I'm mezmorized. Why doesn't it catch? Anyone got any quick tips??

alexprice
Mar 23, 2005, 12:20 PM
Hello all. I just obtained a 500mhz iBook G3 that is in great condition and running smooth. Right when I got it, I booted it and it was running Jaguar. Right then I noticed the trackpad or button wasn't working at all...I plugged in an external Apple USB mouse, and bang...a moving cursor. I upgraded it to Panther, a complete fresh install, and everything. Currently, it has every update out, I have reset the power management and all. I assume it might be a physical thing and perhaps the cable is loose or not plugged in...If that's the case, anyone have any instructions as to how I would go about checking that? I appreciate it and can't wait to hear from you all!

Edit: Oh, also...In the prefs, there is NO panel for a trackpad like there is on my PB G4. Thanks

P.S.: Besides that, the only other problem is that the latch doesn't catch, it comes down when it get to it, the button presses in and out, but nothing..I'm mezmorized. Why doesn't it catch? Anyone got any quick tips??

Hello, ok it sounds like the cable is loose, power the unit off, remove the battery, remove the keyboard, remove the airport card (if there is one!), remove the little plate underneath, find the orange ribbon cable and CAREFULLY reseat the cable. The connector that the cable plugs into has a little clip that you pull upwards to release, just be VERY gentle!

Hope this helps!!!!

Alex