PDA

View Full Version : Powerbook G4 stuck on grey apple screen... PLEASE HELP




kreganmusic
Jun 8, 2011, 01:47 AM
Hey everyone..

Earlier today I tried to install the latest update for my Powerbook G4. It showed a message saying it could not be installed. I tried to reboot and now the comp is stuck on the grey Apple screen. It doesn't even show the time clock symbol. I have tried everything I could find listed in various forums to remedy this problem and have come up empty every time. My main use of this computer is as a recording device in my studio. My music is my life and EVERYTHING I've recorded in the past six years is on that computer. If I lose these files, I have nothing to show for my past 6 years of work. Needless to say this has me so depressed that I do not know where else to turn. I really hope somebody here can help me. I can't tell you all how much I'd appreciate it. I hope to hear from you guys soon. Take care and thanks in advance.



Badrottie
Jun 8, 2011, 03:13 AM
sorry to hear but you should have back up your data in case of serious havoc on your powerbook. I hope someone will be able to help you soon