PDA

View Full Version : Validating App - armv6 missing




dant19
Jun 11, 2011, 05:25 AM
I am validating my first App ready to submit and I keep getting the following warning:

iPhone/iPod Touch: application executable is missing a required architecture. At least one of the following architecture(s) must be present: armv6.

I have been into the "Build Settings" of the application and under architectures what is selected is:

Standard (armv7)

When I try to change it there are no other options.

Any thoughts?

Thanks
Dan



North Bronson
Jun 13, 2011, 12:21 PM
I am validating my first App ready to submit and I keep getting the following warning:



I have been into the "Build Settings" of the application and under architectures what is selected is:

Standard (armv7)

When I try to change it there are no other options.

Any thoughts?

Thanks
Dan

I've seen this a couple of times. How old is the Xcode project?

You can try starting a new Xcode project from scratch and import all of the old resources and code. I've seen it work.