PDA

View Full Version : PowerBook won't turn on!




d88co88
Jun 28, 2011, 11:17 AM
Hi, I have a 12 inch, 1.5 GHz PowerBook G4 that is having problems. I
shut it down as the bluetooth wasn't being recognized, and when I turned it on, it didn't chime or give anything onscreen. What the heck is wrong? I've tried a pram reset, pmu, tried going into open firmware, and it won't eject any discs with the mouse down. Any input is appreciated!



adcx64
Jun 28, 2011, 11:57 AM
Bad RAM maybe? Try removing the battery or other external devices.

d88co88
Jun 28, 2011, 12:05 PM
Tried it without the ram in, no dice. It turns on, I can hear fans spinning and the optical drive working, but nothing else. I've also tried it with an external monitor, that didn't work either. :(

adcx64
Jun 28, 2011, 12:27 PM
It defiantly wouldn't work without the ram in! I meant to try different sticks of ram. :o

d88co88
Jun 28, 2011, 12:39 PM
Oh, no this has 256 mb onboard so it did have some in it haha!

adcx64
Jun 28, 2011, 01:22 PM
Oh..:rolleyes:

Maybe try removing the PRAM battery if you can get to it.

brycemason
Jun 29, 2011, 12:21 AM
I do not believe the 12 inch model has a PRAM battery. There is a very short-term capacitor that keeps the time and date for about 15 seconds between battery changes.