PDA

View Full Version : building speex library on iPhone




techgentsia
Jul 19, 2011, 02:30 AM
I am trying to build speex library for iphone. I edited the makefile from i386 to ARM but on configuring it automatically changes back to i386. Also i tried to change the host and build in commandline(make --host=arm-apple-darwin10 --build=arm-apple-darwin10). But it says "This program built for i386-apple-darwin10.0". Where should i change to compile for ARM or should i need to write a new makefile for ARM. I am new to makefiles and iOS. Please someone help me to solve this out.
Thanks in advance.



techgentsia
Jul 24, 2011, 11:47 PM
Solved myself :) .Started an iOS static library project and builded the source code(src, libspeex). Link the header search path to speex.h(/include/speex/speex.h) in project target. Done. Hope this helps someone.

Dreyk
Sep 2, 2011, 10:52 PM
Can you explain me how to compile the library, and how to use?
I can't compile the library.
Please help me. And what src you downloaded?

firewood
Sep 5, 2011, 01:44 PM
I can't compile the library.

Did you import the source code into an Xcode project?