PDA

View Full Version : Wi-Fi range issue with new MBA 13 and Netgear WNR 2200 router




redhot47fl
Jul 22, 2011, 11:17 PM
Loving the new MBA 13 (my first Mac), but running into a frustrating wi-fi issue.

The MBA wi-fi flies when the machine is in the same room as the NetGear WNR2200 router, but it slows down considerably as I move it through our (smallish) house, and it pretty much crawls to a stop just 10 yards or so away from the router.

The MBA's range icon never changes, showing a strong, four-band signal, but the performance drops sharply. Other devices, including a 3-year-old Dell laptop, receive strong wi-fi signals throughout our house. (I haven't yet had a chance to test this 2-day-old MBA with any other wi-fi signals.)

I see some previous issues posted on this board regarding NetGears and Macs, but nothing I do seems to help. Any similar experiences? Any new hints regarding a resolution short of buying a Time Capsule, which I eventually will probably do anyway?

Also, the wi-fi icon indicates a frequent, every 20 seconds or so, search for new networks. Is this normal?



redhot47fl
Jul 23, 2011, 02:20 PM
Just for the record...never mind.

It turns out that the new MBA's wi-fi range was just fine, performing wonderfully on other networks in other places using other routers.

The problem was an unresolved (and probably never-to-be-resolved) incompatability between the MBA and the NetGear NR2200 router, a problem that has been documented from time to time in the past.

I've replaced that router with an older D-Link, and the reception and connection speed are now flawless throughout my house. That said, I'll probably spring for a Time Capsule in a few weeks.