PDA

View Full Version : MBA 11" 1.4/64GB Win7 Boot Camp Install Issue




jfriedman8
Jul 23, 2011, 12:14 PM
I am trying to install Win7 on my 11" MBA today to no avail. I've done this a million times before with my MP, iMac, and MBP, but I have no clue what I am doing wrong this time.

I used bootcamp (I'm using Lion) to partition for Win7 at 20GB. Obviously it formats it in FAT, not NTFS. When I get to the win7 install screen, I reformat it and it installs fine. Windows boots up, the trackpad works, but NOTHING else. The install stick that has all of the bootcamp prefs and drivers does not get recognized at all. Basically, I cannot do anything other than play with the mouse and click around everything that comes with the startup disc. No internet or anything.

Should I try and make a copy of the install stick and use another USB device? Any suggestions?



coolbreeze
Jul 23, 2011, 12:38 PM
Exact same issue here with Win7 64-bit. I was able to make an .iso of the disc, had all three boxes checked on the bootcamp install screen, formatted Windows on install, booted into Windows. This is when the issues began.

Obviously, without any drivers installed, the resolution is poor, no internet, sound, etc. Just basic functions. So I inserted the thumb drive and opened the Windows support folder. Found setup.exe, double clicked on it. I got some strange error that I can't remember...basically, nothing worked when trying to install the bootcamp drivers.

So, I'm completely stuck. Frustrating because like the OP, I've easily installed bootcamp on many, many macs in the past.

Not sure what's wrong...maybe Wind7 64-bit is not compatible? Should I try 32-bit? I don't want 32-bit due to it not recognizing 4-gigs of ram.

Help!

jfriedman8
Jul 23, 2011, 01:35 PM
At least yours is recognizing the thumb drive! I am thinking about doing a clean Lion install from an SD card and trying again if I can't figure this out today.

Anyone else having the same issue or have a fix?

coolbreeze
Jul 23, 2011, 01:50 PM
This is the error I get when trying to run setup.exe (to install bootcamp drivers in Windows 7).

Frustrating at best.

coolbreeze
Jul 23, 2011, 05:12 PM
Nevermind. I'm a complete idiot. I used a vista .iso instead of Windows 7.

Now that I undid bootcamp, then re-did it with the correct Win7 .iso, everything is working perfectly now!

So, moral of the story is Apple only supports Win7 when using bootcamp.

jfriedman8
Jul 24, 2011, 12:06 AM
Still nothing working on my end and I'm using a purchased Win7 disk. Won't recognize any USB devices I plug in when in Windows side, no sound, wifi, ect.

rustyosaurus
Jul 24, 2011, 12:17 AM
i had a weird issue when installing win7 via vmware fusion - it wouldn't recognize the superdrive.

finally got it to work by setting up the virtual machine first, trying to connect to it a number of times and finally it worked. actually, i think it was the reboot that got it to work - for whatever reason.