PDA

View Full Version : Resistor soldered on my Cube motherboard?




CDuv
Jul 24, 2011, 11:42 AM
Hello,

I've got my hands on a PowerPC G4 Cube (PowerMac5,1: G4 450MHz / 1Go RAM / running MOX 10.4.11) that has random shutdown/sleep problem: computer goes to sleep every 3 minutes or less.

It looks like both :
- a PSU connector issue: sometimes, if I touch the PSU plug when the computer is running, it goes to sleep or reboot
- an unstable something-I-can't-determine-what-it-is: the computer goes to sleep without anything have moved (psu, cable, table, etc.) or been clicked (mouse, keyboard).

I tried to reset the CUDA/PMU (http://support.apple.com/kb/HT1939): didn't changed anything.
When the Cube was opened I noticed that a resistor was soldered on a chip as can be seen on the following image:
http://img811.imageshack.us/img811/4269/globalview.jpg (http://imageshack.us/photo/my-images/811/globalview.jpg/)

I can't find what possible hack this resistor is related to.

Would somebody have an idea?



adcx64
Jul 24, 2011, 11:48 AM
The reddish color of the "resistor" makes it look more like a Zener diode.
The silver component next to it looks like a diode as well.

I doubt either things are original, maybe it was an attempted over clock that rendered the system unstable.

firestarter
Jul 24, 2011, 11:50 AM
It's not a resistor.

It looks like a zener diode (the red one) and possibly a constant current diode (or a signal diode - don't know) soldered back to back.

The large surface mount chip underneath looks like a power IC, possibly a driver or more likely a regulator.

Possibly this is some factory rework to change the power being sent to another IC... maybe they ran out of 5v parts and fitted 3.3v parts and changed this... could be anything really.

CDuv
Jul 24, 2011, 12:47 PM
The chip thoses things are soldered on have the following inscriptions:
JM04AP
LM2679
S-ADJ

And you were right: there is 2 things, soldered back to back :
reddish:Z
IN
[...]

greyish:IN52
31B
019

I also noticed a big component labeled "100 B1" on the right of the 2 diods that seems to have been resoldered too.

Close-ups:
http://img715.imageshack.us/img715/6661/diodsandchip.th.jpg (http://imageshack.us/photo/my-images/715/diodsandchip.jpg/) http://img33.imageshack.us/img33/3430/bigthingresolderd.th.jpg (http://imageshack.us/photo/my-images/33/bigthingresolderd.jpg/)

Could I just "remove" the diodes?

adcx64
Jul 24, 2011, 12:59 PM
Since you don't know if the diodes are from the factory, you shouldn't unsolder them since it could cause harm to the board.

firestarter
Jul 24, 2011, 01:13 PM
The chip is a voltage regulator. The power supply to the board probably supplies 12 and 5v, this regulator is a switching regulator which probably drops that to 3.3V. Switching regulators switch power on and off at a high frequency (>200kHz in this case) in order to change voltage in a circuit.

Here's a datasheet (http://www.national.com/ds/LM/LM2679.pdf) for it.

The diodes are both zeners - and both connected back to back (the black ring on each points in opposing directions). This arrangement is commonly used to 'clip' an AC signal, keeping it within certain boundaries - without affecting normal operation of a circuit.

They're connected between pins 2 and 3 on the regulator - which isn't an arrangement recommended in the datasheet (pin 2 is input voltage, pin 3 is a 'boost' used to increase the drive on, and lower the switching resistance in the regulator). Using zeners like this doesn't have any obvious use to me! Possibly they're there to try and protect the IC from reverse voltages in the inductor... but using those pins is an odd choice.

100B1 is probably an inductor, used in the circuit as a filter.

At one point the power supply probably failed. The inductor was replaced and the zeners put there as some preventative measure. I'm not sure if it'll work any better with them removed - but if you really wanted to try that, you should de-solder them from each other where they join, as it would be easier to solder them together again at that point (if they're required) rather than soldering to the IC pins.

If you can't solder, and don't have test tools to check the regulator function, I'd give up at this point. Just cutting links and messing around isn't going to make it work better!

CubeHacker
Jul 24, 2011, 01:14 PM
When your cube is on, look at the top power button. Is the light from the button steady, or does it seem to dim/brighten at random? Some cubes have problems with the power button causing random "phantom" presses, which tends to put the cube to sleep, shut it down, and occasionally wake it up. Usually a simple gasket cleaning for the power button is enough to fix it, but sometimes the button needs to be replaced. Before doing anything drastic, I would try to figure out if this is the cause of the problem, as its a common issues with cubes.

sporadicMotion
Jul 24, 2011, 01:15 PM
Since you don't know if the diodes are from the factory, you shouldn't unsolder them since it could cause harm to the board.

Those don't look stock. The solder jobs look home brew.

If the machine is already malfunctioning, try removing them to see if it's a fix. If it doesn't work, return them to where they came from. As long as you don't create a short anywhere, you probably won't cause more damage.

EDIT: +1 to what firestarter said

adcx64
Jul 24, 2011, 01:49 PM
Those don't look stock. The solder jobs look home brew.

True. I wonder what the original owner was trying to do though.....

CDuv
Jul 24, 2011, 02:46 PM
Thank you for all theses detailed informations.

I'll try what CubeHacker (http://forums.macrumors.com/member.php?u=16428) suggested (look at the top power button light) as I really felt like it was phantom presses sometimes.

Sorry to ask but I don't understand the "a simple gasket cleaning" part: can't find the "gasket" that can be cleaned.

Or the second time: will properly unsolder the two zeners as advised by firestarter (http://forums.macrumors.com/member.php?u=13727).

CubeHacker
Jul 24, 2011, 03:01 PM
Sorry, I should have went into more detail about the gasket.

manuals.info.apple.com/en_US/gasket.cube.pdf

Those are instructions on how to replace the gasket. Chances are you won't need to replace it, just remove it, wash it in some warm water, let it dry out completely, and replace it. My cube had the same symptoms as yours, and this procedure fixed it. Others had to try more radical measures, such as putting a piece of paper between the sensor and the cube case. A quick search online should reveal several threads on the topic.

Edit: A quick way to determine if the power button/gasket is the problem is this: go into system preferences, and uncheck the box that reads "allow the power button to put the computer to sleep". This should prevent the computer from randomly going to sleep, but will NOT prevent it from turning off, as some of the phantom presses might be 3+ seconds long, which forces the PSU to shut off and cannot be bypassed through software. If unchecking that box stops the random sleeps, then the problem is 100% the gasket/power button.