PDA

View Full Version : Problems, problems and more problems




tribaltek
Jul 29, 2011, 04:15 PM
I unfortunately upgraded to Lion when it was released. I did this not knowing it would kill my AFP connection to my NAS for Time Machine backups, break my bootcamp partition, and render my printer inoperable.

But, I said what the heck and wiped everything and did a clean install thinking it must have just been an upgrade issue. Guess not.

If anyone has any advice, here are just a few of the issues I'm having.

1) Bootcamp assistant opens up by itself every time I log in.

2) Connection to NAS requests ID/PW every time I log in (even though I check the save to keychain box).

3) Any time I try to delete files, it prompts me for my login credentials.

4) Icons I remove from the dock are mysteriously back upon login.

5) Icons I add to the dock are mysteriously missing upon login.

6) Chrome asks every time it loads if I want it to be the default browser. It doesn't matter what I click, it asks the same thing each time it loads. Chrome also never loads in the same screen position that I close it.

7) When I open, say, Textedit, it will open previous documents (some of which I've since deleted - yet they still open). Is this a "feature" of Lion? If so, how do I turn it off?

I know there are more, but those are some of the more annoying ones.

For reference, my account is an admin account. I have ran repair disk permissions via disk utility. I've assigned read & write permissions for my account to my home folder (and selected apply to enclosed items).

I've been using Macs exclusively since 10.3 and have never had the issues I'm having with 10.7.

Any input would be greatly appreciated!



tribaltek
Jul 29, 2011, 06:10 PM
Just installed and ran Onyx Beta, because I really have no idea what to do otherwise. Didn't fix any of the above issues.

robgendreau
Jul 29, 2011, 07:06 PM
What do you mean by "clean install"? Were the problems present when you installed following Apple's installer's directions? Or only after you wiped your drive?

Sounds like a permissions and/or user account issue.

Garen
Jul 29, 2011, 07:10 PM
Don't have Lion installed yet but did you try creating another user account and see if it will work as intended?

Garen:)

tribaltek
Jul 29, 2011, 07:19 PM
What do you mean by "clean install"? Were the problems present when you installed following Apple's installer's directions? Or only after you wiped your drive?

Sounds like a permissions and/or user account issue.

These specific issues didn't appear to be present at the time, but there were several others. It sounds like permissions to me as well, but I'm unsure how to resolve.

Don't have Lion installed yet but did you try creating another user account and see if it will work as intended?

Garen:)

Good call. Tried my other admin account and it doesn't seem to have all of the same issue. Hmph... now how to resolve this...

Hugh
Jul 29, 2011, 07:38 PM
These specific issues didn't appear to be present at the time, but there were several others. It sounds like permissions to me as well, but I'm unsure how to resolve.


To get Mac OS X to repair permissions. Go to DISK UTILITIES and click on your hard drive, then click on Repair Permissions. This might help or might not, nothing to lose by trying it though.

tribaltek
Jul 29, 2011, 07:51 PM
To get Mac OS X to repair permissions. Go to DISK UTILITIES and click on your hard drive, then click on Repair Permissions. This might help or might not, nothing to lose by trying it though.

I've done that. Mentioned in the original post.

Toke
Jul 30, 2011, 08:11 AM
7) When I open, say, Textedit, it will open previous documents (some of which I've since deleted - yet they still open). Is this a "feature" of Lion? If so, how do I turn it off?
I believe the way to fix this is to go into System Preferences then go to General and find the check box where it says 'Restore Windows when quitting and re-opening apps' and uncheck it.

tribaltek
Jul 30, 2011, 09:48 AM
I believe the way to fix this is to go into System Preferences then go to General and find the check box where it says 'Restore Windows when quitting and re-opening apps' and uncheck it.

That fixed that. Thanks a ton. That was so damn annoying!!!

Now I just need to fix the permissions issues and I should be good to go.

tribaltek
Jul 30, 2011, 10:44 AM
Created a new account for myself and ported everything over to said account. Should be good to go now. :cool: