PDA

View Full Version : Lion: address book: can't add new card




jacksnack
Jul 30, 2011, 03:13 AM
Today suddenly my address book isn't working properly anymore. I can't add new cards. When I want, address book hangs.

Couldn't find a solution yet.

What I tried:
imported backup (abbu) and older backups. Didn't work
deleted the abcddb file (Library/Application Support/Adress book). Didn't work
Did a reinstall of the addressbook from the Lion "disk". Didn't work
Repaired Disk Permissions. Didn't work

I can, however add info to existing cards.

Suggestions anyone?

++EDIT and solved++
For those:
First make a backup of the address book!
I deleted the address book with app zapper. So also the map Library/Application Support/Adress book was deleted. Check if that happened. If not, do it manually.
The address book app has been deleted.
Restart
Open the Lion dmg and find the package address book. Install it (double click).
Restart
Double click the backup abbu file (you made earlier) in Finder. Do NOT import this backup through address book "import" option! Once this backup has been put back in address book you can open address book as normal.
Don't have a clue why I got these problems, but this procedure worked for me.



rgmichel
Aug 23, 2011, 02:46 PM
After talking to an Apple support person, I found the following allowed me to edit the address book in Lion, and it solved a number of niggling problems too. My issues were caused by permissions and ACL attributes.

I restarted my computer and pressed command-R during the restart. This brought up the utilities menu. I then ran Terminal, and typed resetpassword, which is all one word into Terminal. This redid all my permissions and ACLs and I now could edit my address book again, and problems with MobileMe and my Drobo RAID were solved at the same time.