PDA

View Full Version : Lion only sleeps if no programs are running




smoker
Jul 30, 2011, 03:15 AM
With Snow Leopard (and all the OS X versions before) my Macs went to sleep at the set time by themselves. Since I installed Lion, my MacBook Pro only goes to sleep by itself as long as there is no Program (Mail, iTunes etc.) running. It still goes to sleep when I close the lid, but not automatically anymore (unless I shut all the running applications).

Is that normal?



syncfield
Aug 7, 2011, 11:33 AM
I'm having the same problem on my MacBook Pro 13" as well. It didn't sleep properly with Snow Leopard either and I hoped the upgrade to Lion would fix it. I managed to get it to sleep automatically after a reboot before opening any applications. But if I use the computer for anything at all then it seems the automatic sleep stops working. It will sleep if I close the lid though.

I made sure Internet Sharing is turned off and a few other tips I found on the internet but nothing seems to help. I wonder if it has to do with Skype and/or FaceTime. Perhaps telephony like apps prevent auto-sleep.

I wouldn't say it's normal. If anyone has found a solution then please post to this thread.

Cheers!!

basher
Aug 7, 2011, 12:57 PM
Odd. I can sleep my MBP with apps running. My iMac never sleeps on it's own

Sarsay
Aug 7, 2011, 01:04 PM
My MBA is somehow slow to put itself to sleep: when I tell him to it goes black screen - with the mouse still visible - and then after 20 seconds or so he enters the real sleep mode. But I have to say that I don't have these problems when I close the screen... :)

Ronnoco
Aug 7, 2011, 01:59 PM
I've been having some sleep issues with Lion when connected to my ACD. It sleeps but seems to go into deep sleep mode and doesn't wake unless I press the power button for a few seconds...truly annoying...:mad:
I don't have the issue with my 11" MBA with Lion...

srf4real
Aug 7, 2011, 06:13 PM
I left my 2011 mini yesterday evening set to sleep in 2 minutes.. came back home this evening and Lion was still ready to go. I had photoshop open, nothing else. This isn't the first time either that sleep has been buggy and wake/restart is also buggy sometimes opening apps that I wasn't even running before shutdown, or opening apps that I was using, even though system prefs is instructed not to do so.

I am growing more and more unhappy, just because after two weeks I expected to know the OS and be moving into stealth operation.. instead I am dealing with too much unpredictability from Lion.

balamw
Aug 7, 2011, 06:15 PM
My MBP is experiencing similar issues. Leaving it open connected to power and Ethernet would usually lead to sleep under SL, but now it stays awake unless I close the lid or :apple:->Sleep.

B

syncfield
Aug 8, 2011, 03:14 AM
OK Guys!! I've finally worked it out!!! Mystery solved.

Through process of elimination I figured out that the native Mail client and iCal were preventing my Macbook Pro from sleeping. "Check for new mail" was set to every minute and "Refresh Calendars" for both my Exchange accounts were set to every minute in iCal as well. It was the background polling operations in these apps that prevented the sleep timer from completing.

SYMPTOM:
MacOS Lion does not go to sleep when Mail and iCal are running. (Other apps with background operations may also prevent sleep mode.)

STEPS to REPRODUCE:
Set your sleep timer to 1 minute. Reboot the machine and ensure nothing is running except "Finder". Observe that the machine sleeps after 1 minute of inactivity. Open Mail and/or iCal (or other apps you typically run) and observe that the machine will no longer sleep.

CAUSE:
Mail and iCal are set to poll for changes at 1 minute intervals thus preventing the sleep timer from completing.

SOLUTION:
Go to Mail preferences and change "Check for new messages" to the 15 minute default. Go to iCal preferences -> Accounts and set "Refresh Calendar" interval for all of your accounts to the 15 minute default. Now the machine will sleep properly as long as you set the sleep timer to < 15 minutes.

CONCLUSION:
Mail and iCal have bugs related to the background polling process. Background processes should not reset the sleep timer.

NOTES:
By design, MacOS Lion will NOT sleep if "Internet Sharing" is enabled even if you manually select "Sleep" or close the lid on a laptop. Ensure Internet Sharing is disabled when you're not using it so that your machine can sleep and conserve power.

If Mail and iCal aren't preventing your machine from sleeping then another application most likely is. Open the apps one-by-one until you find the one that is preventing sleep.

By design, Lion will not sleep if an iDisk (MobileMe) sync is in progress. The machine should sleep normally when the synchronisation is complete.

jkcmac
Aug 8, 2011, 03:56 AM
I notice mine too when left my safari download continue it doesn't sleep over the night. I mean even the download are completed.

syncfield
Aug 8, 2011, 04:13 AM
Ah yes!! I bet the system won't go to sleep if Safari or iTunes are busy downloading something in the background. Same reason why an iDisk sync prevents sleep.

BTW, if you use Exchange for email and calendars then you can set Mail and iCal to only check for new messages/sync manually. Exchange pushes new email and calendars so polling is unnecessary. If you turn the background polling off completely then the system will sleep properly even if the timer is set to 1 hour.

balamw
Aug 12, 2011, 09:17 PM
My MBP is experiencing similar issues.

FWIW Traced my sleep issues back to the HP agent for supporting Time Machine backup to my Mediasmart server (Windows Home Server). Moved the backup over to a WD My Book Live. My MBP sleeps again.

B

srf4real
Aug 12, 2011, 10:58 PM
Leopard went to sleep when I told it to. Why can't Lion? It stays awake all night or all day after blacking out screens and making me think it's obeyed - when all apps are closed. I go to it hours later expecting to log in and my desktop is sitting there waiting for me. Not good, not professional, not how I expect anything Apple to behave, (misbehave).

It's gotten to where I just power off the 2011 mini to ensure my security. I hope they fix this in 10.7.2:mad:

Blue Sun
Aug 13, 2011, 12:03 AM
Hey guys.

I have a solution.

Download PleaseSleep (http://www.dragonone.com/products/macosx/pleasesleep/), it puts the Mac to sleep when the allotted time in the Energy Saver preferences has been reached (overriding any applications unless you have them set to keep the keep the Mac awake).

It has been updated for Lion and I've been using it for years with Snow Leopard and it works perfectly. It uses barely any resources and I can't recommend it enough if your Mac doesn't sleep when it should.

BiggAW
Aug 13, 2011, 07:44 AM
Same issue here, mine will never go to sleep, so I just force it to go to sleep manually.

nuno.bett
Aug 29, 2011, 09:39 AM
same thing here late 2010 MBA running Lion.