PDA

View Full Version : Keyboard randomly stops working




baryon
Aug 1, 2011, 09:03 AM
Sometimes I'm trying to type something and I realize that nothing's getting typed when I press the keys. I don't know what causes this and when exactly it happens, but so far I have not been able to make it go away unless I reboot.

When the keyboard stops working, it's completely dead: Not only can I not type, but key combinations like [ Cmd + W ] and [ Alt + Arrow keys ] for swapping Desktops doesn't work either. As I remember though, the light on Caps Lock still works normally.

Within one week it has happened to me twice so far, and I rebooted each time and that fixed it.



wadey
Aug 3, 2011, 06:10 PM
I'm having the exact same problem with Lion. One time I tried putting the computer to sleep and bringing it back but the keyboard still did not work (and I could not type password to get back in).

The next time it happened I logged out of my account and the keyboard started working again on the login screen. Can you confirm the same behavior?

Also, maybe we can find out if a specific app is causing this. I believe that I was using either MacVim or iTerm2 both times this happened to me, can you correlate with that?

bmauter
Aug 10, 2011, 10:46 AM
My 2007 15" MacBookPro does this too after upgrading to Lion. It also happened after a fresh install of Lion rather than just the upgrade. Caps lock key light and num lock key lights work. I logged out and the keyboard started working when I tried to login.

I saw that killing the dock would fix it, but I haven't tried it yet.
http://answers.downloadatoz.com/q,11913,usb-keyboard-stopped-responding-working-in-mac-os-x-lion-how-to-fix.html

chrisrk7
Aug 19, 2011, 02:39 PM
I have a 17" MacBook Pro from 2007 (OSX 10.4.11) that's doing the same thing: the keyboard arbitrarily decides to stop working and I usually have to reset to fix it. A couple times I was able to regain use simply by going to a different program. I never had this problem before, but in the last month or so it has stopped working about 8 or 9 times.

I don't know if it's related, but in the past couple days I noticed a significantly slower processor speed, one that leaves me staring at the spinning rainbow of doom far too often for far too long and it is starting to drive me crazy. I don't mean to derail this thread, I just don't know whether or not it could be relevant to diagnosing the problem and thought I'd rather be safe than sorry, so-to-speak.

Help!

viruz.360
Sep 6, 2011, 04:51 AM
I'm having this exact same problem.

Sometimes it happens just randomly, but it also happens anytime I switch to Dashboard using ctrl-left.

I've resorted to just opening Activity Monitor (using only the mouse...) and killing the Dock process.

I'm using a fresh install of Lion on my Late 2008 MacBook Pro.

edit: I narrowed down the problem:

I disabled Dashboard as per this hint: http://www.macworld.com/article/46236/2005/08/disabledashboard.html

Now, If I press crtl-left, dashboard doesn't appear but the keyboard still freezes.
I also noticed that it freezes when pressing crlt-right (but not ctrl-up/down).

I suppose this has something to do with spaces (but AFAIK you can't disable spaces in Lion).

edit: I attached a small applescript-app to kill the Dock (easier than going to activity monitor everytime).

Also, do any of you use a DisplayLink device with your mac? There might be a link between the DisplayLink drivers and the keyboard lockup problem.

quietstormSD
Sep 6, 2011, 06:35 AM
I had this problem with a late 2007 Macbook Pro 15" model. I read in a forum somewhere where someone had a similar issue and it appeared that a ribbon cable beneath the battery apparently warped or became more lose. The simple fix was to place a sticky-note folded up placed in between the copper-ish cable and the battery and carefully close the battery. This worked for me. If you have a unibody Mac this obviously won't work since you can't remove the battery.

This person appears to have the same or similar problem.

http://lbarclay.wordpress.com/2009/01/29/macbook-pro-trakpad-and-keyboard-not-working/

MasterHowl
Nov 17, 2012, 09:04 AM
I'm having this exact same problem at the moment as well. It happened once a week with Lion, but it happenes at least once a day with ML.

I've got a mid-2009 15-inch MBP. So frustrating.

Anyone got a fix?