PDA

View Full Version : Host name settings?




Celeron
Aug 1, 2011, 05:44 PM
Is there a recommended procedure for installing / setting up Server with regards to the host name configuration? I've been doing it like this:

1. Install Lion.

2. Set the server name in the "Sharing" panel of System Preferences.

3. Install Server.app

4. Use Change Host name wizard to change it to the fully qualified host name, such as "server1.mydomain.com."

5. Configure all my services.

Is this the proper way to do this? I'm finding annoying side effects, like iChat only accepting logins when the user name is "user1@server1.mydomain.com" instead of "user1@mydomain.com" which is what I expect.

Any input or suggestions would be most helpful!



jackhdev
Aug 1, 2011, 06:13 PM
Yes, that is how you should do it. Set up your host name to be example.com instead of server.example.com. Also, which ports do you use to access the iChat service?

Celeron
Aug 1, 2011, 06:35 PM
Yes, that is how you should do it. Set up your host name to be example.com instead of server.example.com. Also, which ports do you use to access the iChat service?

I thought of using just the domain name but the documentation from apple.com seems to suggest it needs to be a hostname and not just a domain name.

I'm using whatever the standard ports are for iChat. I'm only testing it internally now, so its 5222 or 5223.

Celeron
Aug 1, 2011, 07:22 PM
I figured out the ichat thing without having to redo the hostname stuff. Just configure an extra domain via serveradmin:

sudo serveradmin settings
jabber:hostsCommaDelimitedString = "server1.example.com, example.com"
<ctrl+d>

Then, bounce the iChat service:
sudo serveradmin stop jabber
sudo serveradmin start jabber

Now I can login using "user1@example.com" and it works fine. Woot.

foidulus
Nov 25, 2011, 07:46 PM
Maybe Lion fixed this, but I recall that sometimes just changing the name in the sharing preference pane doesn't set the hostname necessary for certain unix services to work.

You can verify this with the scutil command

scutil --get HostName

if the hostname is wrong, you can set it with

sudo scutil --set HostName (your host name)

rwwest7
Nov 25, 2011, 09:35 PM
Maybe Lion fixed this, but I recall that sometimes just changing the name in the sharing preference pane doesn't set the hostname necessary for certain unix services to work.

You can verify this with the scutil command

scutil --get HostName

if the hostname is wrong, you can set it with

sudo scutil --set HostName (your host name)

Not fixed, you have to use server.app or else it's still the old name.