PDA

View Full Version : No more left click




everc
Aug 1, 2011, 09:15 PM
Hi, guys,
I start to use lion on its official release date.
However, recently I encounter an issue that the trackpad left click function is missing. When it happens the first time, restart Lion solved the problem. But now the issue persists.
I thought it was a hardware issue, but it is not. It is the same for my USB mouse as well. The mouse can move, right click, multi-gestures except left click.
So I conclude it is a software problem, so did this issue happen to any one? What is the solution?

Thanks.



Steve's Barber
Aug 1, 2011, 09:31 PM
Left clicking works for me. Never a problem. I also have "tap to click" toggled on in system preferences.

I don't know why that's happening to you; right clicking works on both my MBP's trackpad and magic mouse. Have you tried making sure it's turned on in settings?

He probably doesn't care if your right click works because his does as well.

everc
Aug 1, 2011, 10:08 PM
Thanks for the replies.
I found out why.
Stupid me: I forgot to turn off my magic mouse which is in my travelling bag with lots of stuff.:p

klamse25
Aug 1, 2011, 10:14 PM
Haha I didn't expect that to be the problem! Glad you fixed it. :p