PDA

View Full Version : Trouble mounting AFP with Lion




BeatCrazy
Aug 3, 2011, 05:37 PM
Hello,

I'm a bit new to Mac OS in general, but I think I understand enough to be dangerous ;)

I am trying to mount a share I have on my local NAS, so it automatically mounts upon reboot of my new Mac mini.

I created the mount point, and folder as /mnt/Share

The command I run is:

mount -t afp "afp://nas-xx-xx-xx (AFP)._afpovertcp._tcp.local/Share" /mnt/Share

If I run when the share is already manually mounted, I get:
mount_afp: the volumen is already mounted

If I run after a reboot, and the share is not mounted, I get:

mount_afp: AFPMountURL returned error 1, errno is 1

What am I doing wrong?



djrbx
Aug 3, 2011, 05:46 PM
Another way to do it is to connect to your share and have it mounted. Go into your system preferences --> users & groups --> login items (for the account in question)
Click on the plus sign on the bottom to add a new item and choose the share you want automatically mounted upon reboot.

BeatCrazy
Aug 3, 2011, 06:23 PM
Another way to do it is to connect to your share and have it mounted. Go into your system preferences --> users & groups --> login items (for the account in question)
Click on the plus sign on the bottom to add a new item and choose the share you want automatically mounted upon reboot.

Awesome! Thank you, that worked. Is there any way to prevent the pop-up windows showing the mounted AFP share every time you boot? Or at least minimize the windows?

This is my first Mac. I should have known these things could be simple, if you know where to look :D

BeatCrazy
Aug 3, 2011, 08:23 PM
Is there any way to prevent the pop-up windows showing the mounted AFP share every time you boot?

Ooops, I found it. Just check the box for Hide.

EDIT: actually, that doesn't work! Windows still pop open for that share-mount when I reboot.

BeatCrazy
Aug 4, 2011, 09:46 AM
Got this working, but the auto-mounted shares always launch a window on the the desktop upon boot up.

Any way to disable this?