PDA

View Full Version : Where is my spotlight?




xineun
Aug 5, 2011, 02:12 AM
When I was using snow leopard, I disabled spotlight by using method below:

sudo mdutil -a -i off
sudo chmod 600 /System/Library/CoreServices/Search.bundle/Contents/MacOS/Search
killall SystemUIServer
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

After upgraded to lion, I did following steps:

sudo mdutil -a -i on
sudo chmod 777 /System/Library/CoreServices/Search.bundle/Contents/MacOS/Search
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

I can search stuff in finder now, but the spotlight icon does not show in the menu bar, and the keyboard shortcut for spotlight does not work. How can I solve this problem?

Thanks!



DewGuy1999
Aug 6, 2011, 09:20 AM
When I was using snow leopard, I disabled spotlight by using method below:

sudo mdutil -a -i off
sudo chmod 600 /System/Library/CoreServices/Search.bundle/Contents/MacOS/Search
killall SystemUIServer
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

After upgraded to lion, I did following steps:

sudo mdutil -a -i on
sudo chmod 777 /System/Library/CoreServices/Search.bundle/Contents/MacOS/Search
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

I can search stuff in finder now, but the spotlight icon does not show in the menu bar, and the keyboard shortcut for spotlight does not work. How can I solve this problem?

Thanks!

I've never done this so it might not work, but from this discussion (http://osxdaily.com/2009/09/20/disable-spotlight-in-mac-os-x-10-6-snow-leopard/) it looks like you might need to run the killall SystemUIServer command to restart the menu.

mrapplegate
Aug 6, 2011, 09:22 AM
When I was using snow leopard, I disabled spotlight by using method below:

sudo mdutil -a -i off
sudo chmod 600 /System/Library/CoreServices/Search.bundle/Contents/MacOS/Search
killall SystemUIServer
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

After upgraded to lion, I did following steps:

sudo mdutil -a -i on
sudo chmod 777 /System/Library/CoreServices/Search.bundle/Contents/MacOS/Search
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

I can search stuff in finder now, but the spotlight icon does not show in the menu bar, and the keyboard shortcut for spotlight does not work. How can I solve this problem?

Thanks!

The only command you should need to turn off spotlight on all volumes is

sudo mdutil -a -i off

Like DewGuy1999 said restart the SystemUIServer

xineun
Aug 7, 2011, 08:50 AM
It does not work. Even restarting the laptop does not work. :(

I've never done this so it might not work, but from this discussion (http://osxdaily.com/2009/09/20/disable-spotlight-in-mac-os-x-10-6-snow-leopard/) it looks like you might need to run the killall SystemUIServer command to restart the menu.

xineun
Aug 7, 2011, 08:53 AM
Yes, I did too many things... I tried to restart the systemuiserver, but it does not work.

The only command you should need to turn off spotlight on all volumes is

sudo mdutil -a -i off

Like DewGuy1999 said restart the SystemUIServer

mrapplegate
Aug 7, 2011, 09:42 AM
Yes, I did too many things... I tried to restart the systemuiserver, but it does not work.

Try to recover the files you changed with TM. Don't know what else to try, they are simple commands and should have reverted when you entered them.

xineun
Aug 7, 2011, 11:02 PM
Try to recover the files you changed with TM. Don't know what else to try, they are simple commands and should have reverted when you entered them.

Thanks, it works. :)