PDA

View Full Version : New MBA Keeps losing space everytime I run VMWARE?




amitdoc2b
Aug 8, 2011, 01:58 PM
Hi.

Based on the recommendation of someone on this forum, I downloaded Space Gremlin from the app store to detect where I may be losing hard drive space. Well, it showed me there are like 7-8 huge 2GB files for Windows 7 under my VMWARE Fusion folder and then some more labelled Windows 7-s0001.vmdk thru s00021.vmdk. I've attached a photo below. Do I need all these repetitive files? Why do they keep coming up, is it because of automatic Windows 7 updates? Which ones can I delete and how do I avoid this from recurring?

Thanks a bunch!



jclardy
Aug 8, 2011, 02:08 PM
Was your VM installed through VMWare or is it a bootcamp partition?

If it was installed through VMWare and it resides on your Mac OSX partition the files may just be the actual windows installation.

VMWare dynamically allocates HDD space as the VM needs it. So if you allocated 30GB when you created it then it would only use around 10GB when you first install. As you go along and download new programs then it will continually allocate more space until it gets to the 30GB limit you set.

ChristianJapan
Aug 8, 2011, 02:25 PM
I would check with VWWare support. It looks a bit strange that you have so many small files inbetween. Did you created and deleted lots data within the virtual machine ? Or had some heavy memory usage causing swapping within virtual machine which would guide to increase of vmdk files temporary.
Whatever you do, I woul NOT delete any of those without support info from VMWare or a real specialist. It might kill the vmdk consistency.

yao
Aug 8, 2011, 02:25 PM
try using shutdown instead of suspend.

amitdoc2b
Aug 8, 2011, 03:12 PM
I actually only use VMWARE fusion for running 1 program, I have not downloaded anything else on Windows using it.

This is actually through VMWARE's website that I got the virtualization program, its not bootcamp.

The only time I ever press "suspend" instead of shutdown is when Windows tries to update files.. and it gets stuck trying to install the updates when I am shutting down/restarting... that's when I hit suspend.

So I have to keep all those different files that are 2.1GB each?

jsolares
Aug 8, 2011, 05:38 PM
I actually only use VMWARE fusion for running 1 program, I have not downloaded anything else on Windows using it.

This is actually through VMWARE's website that I got the virtualization program, its not bootcamp.

The only time I ever press "suspend" instead of shutdown is when Windows tries to update files.. and it gets stuck trying to install the updates when I am shutting down/restarting... that's when I hit suspend.

So I have to keep all those different files that are 2.1GB each?

the "disk" inside VMWare grows up to the defined size you set, you can delete all temporary files in windows or check used space and then compress the disk from the Tools

It's expected behaviour, if you don't wan to "lose" space make VMWare preallocate the virtual hardrive then it wont keep growing.

ChristianJapan
Aug 8, 2011, 06:22 PM
What looks a bit strange are those smaller files with 328 kB. I would assume those should be chunks of 2GB as well as e other bigger files. So I don't understand why they are smaller. Would've interessting where they come from. Too any of them might impact the virtual system as the overhead getting higher to simulate the virtual disk.

johnhackworth
Aug 8, 2011, 07:06 PM
You don't have auto-snapshotting turned on do you? IIRC it's called autoprotect.

smchan
Aug 8, 2011, 07:19 PM
Those files are normal. As previously stated, the might be growing at a fast clip if you're using snapshots.

Here's a blog post (http://techblog.41concepts.com/2008/03/31/shrink-your-windows-disk-image-on-wmware-fusion-mac/) that describes how to shrink virtual disks in Fusion to reclaim disk space. Step 6 is the key step. (And I think step 4 is not really necessary.)

Sam

amitdoc2b
Aug 8, 2011, 07:52 PM
You don't have auto-snapshotting turned on do you? IIRC it's called autoprotect.

No its disabled.