PDA

View Full Version : Cant change site location in server.app




j15big
Aug 8, 2011, 10:42 PM
Im trying to host a website on Lion Server. I enabled web hosting in server.app, but for whatever reason the location of the site defaulted to /var/empty and I cannot change it when I click edit. When I try to visit the web site I get a Forbidden error. I tried to create a new site entry with the same host name but it doesn't work.

Im a noob if you can't tell, any help is appreciated.
Thanks

edit: grammar



RafaelT
Aug 9, 2011, 07:38 AM
This is a common issue, it appears to be a bug in Lion Server... one of many.

There are some settings that can be edited in the apache2 directory. I don't have time to walk you through it right now but if you Google "/var/empty/ lion server" that might point you in the right direction. Someone else here may be able to go into more detail with you as well.

j15big
Aug 9, 2011, 05:50 PM
This is a common issue, it appears to be a bug in Lion Server... one of many.

There are some settings that can be edited in the apache2 directory. I don't have time to walk you through it right now but if you Google "/var/empty/ lion server" that might point you in the right direction. Someone else here may be able to go into more detail with you as well.

Ive tried this:


issue a "sudo su",
type your password
then run the command

echo NameVirtualHost\ \*:80 > /etc/apache2/sites/00000_MoreTestingRequired.conf

or if you have SSL enabled run

echo NameVirtualHost\ \*:443 > /etc/apache2/sites/00000_MoreTestingRequired.conf


didn't seem to work unless i did it wrong. is this what you are referring to?

RafaelT
Aug 9, 2011, 07:28 PM
No, thats not the fix for your issue. You need to edit one of the files and change the document root. I'll see if i can find it later

j15big
Aug 9, 2011, 08:40 PM
No, thats not the fix for your issue. You need to edit one of the files and change the document root. I'll see if i can find it later

Thank you. I appreciate your help.