PDA

View Full Version : version plateaus in OS X




zeppenwolf
Aug 9, 2011, 12:51 AM
I have a machine I still use which can't be upgraded beyond 10.2.8, no way, no how. It's the original iBook, the clam thing, that looks like a blueberry highlited accessory from a hair salon circa 1970... ( Heh. It's still cool, tho )

Now suppose that Xcode currently came with SDK's for 10.4 , 10.3, and 10.2.8 In that case, I would take very seriously trying to make my app back-compat to 10.2.8, because I would figure that alot of people were actually stuck at that plateau just like me-- that it was not just that they were too lazy or whatever to upgrade.

I say all that so that you can tell where I'm coming from: are there similar, hardware intransigent version plateaus keeping alot of people using X.4 ? Or X.5 ?

Or is it the case that everyone using X.4 simply hasn't upgraded, although they could?

IOW, how many users would I be losing, *through no fault of their own*, if I target only X.6 or >= X.5 ?



gnasher729
Aug 9, 2011, 02:12 AM
You have no chance of being compatible with anything before 10.3.9 while running on Lion. XCode 4 ships with 10.7 and 10.6 SDKs only.

I think you should do yourself a favor and write for either 10.6 or 10.7. 10.7 excludes PowerPC and Core Duo. That's five year old machines. Their owners don't buy newer software. And anything else, if they haven't upgraded from 10.4 they are not buying new software; if they haven't spent $29 to upgrade from 10.5 they are not buying new software.