PDA

View Full Version : G4 freezes on boot when HDD is connected




shosterman
Aug 15, 2011, 10:54 PM
Hello all,

A friend asked me to look at his old Powerbook-A1138 and as I usually fix Windows based machines, I figured it would be good practice. (as we now have 2 Macs in the the home, a Macbook Pro and a new Air)

The issue seems to be whenever I physically connect the HDD to the motherboard the system freezes on boot: Grey screen on normal boot, freeze when booting to disc, freeze just before options appear on startup manager. I disconnect the cable and can boot to Startup Manager with the only obvious option of booting to the CD.

Thinking the drive was dead I ran SpinRite on it via a USB to IDE adapter on another PC and it passed with no errors. I have also tried another random Seagate 120GB drive I pulled from a working Windows notebook and formatted to Mac Ext. (Journaled) using the MBP.

I also thought maybe the SuperDrive was bad as it was making a lot of noise when accessing the discs, but even after replacing with another SuperDrive, same noises and nothing. I guess they're all loud. :-)

I've spent hours troubleshooting and not getting anywhere. I'm ready to start again at the beginning if need be. And there's nothing to restore or save, I'm just trying to get a clean system installed. I have original install discs and a Tiger DVD.

I look forward to your help.



Nameci
Aug 15, 2011, 11:28 PM
If you have partitioned using an MBP, the partition would be GPT, while the powerbook needs an APM (Apple partition map).

And be careful if your installer disks are grey they are machine specific, if they are black discs they are retail disks and should be universal. You can't install leopard meant for an intel mac to a PPC mac.

fyi.

shosterman
Aug 16, 2011, 12:06 AM
The grey discs were given to me by the same friend which I did forget to mention. I would assume they are for that machine, OS 10.4.2. The Tiger disc is black.

As for the drive I connected back to the MBP, Disk Utility > Partition > Options and changed the single partition to APM.

With the drive back in the G4 I boot with "C" and get a spinning circle under a Circle with Slash or prohibited symbol.

"Option" boot and the pointer freezes before anything appears. (Only half circle and right-arrow buttons)

I'll continue tomorrow after I get some sleep. :-)

zen.state
Aug 16, 2011, 12:31 AM
Could possibly be a bad logic board HD chipset or something of that nature.