PDA

View Full Version : F4 launchpad key?




BullittMustang
Aug 18, 2011, 10:26 PM
I bought a new apple keyboard that has the F4 launchpad button. The F4 button doesn't work. I'm new to apple and tried everything I could think of. I searched and found a solution that said to delete a file. It seems I don't have that file or can't find it. rm ~/Library/Preferences/com.apple.symbolichotkeys.plist
Does anyone have any solutions?
Thanks



QuarterSwede
Aug 18, 2011, 10:38 PM
System Preferences > Keyboard > Keyboard Shortcuts > Mission Control. No need to hack it.

BullittMustang
Aug 18, 2011, 11:22 PM
Thanks,
I know I'm new to mac, but what is in mission control that will allow F4 to open launchpad? I can go to the launchpad setting in keyboard, check to enable it, but it will not allow an F4 entry.

QuarterSwede
Aug 19, 2011, 07:15 PM
Thanks,
I know I'm new to mac, but what is in mission control that will allow F4 to open launchpad? I can go to the launchpad setting in keyboard, check to enable it, but it will not allow an F4 entry.
Sorry for the late reply.

LaunchPad! So sorry. System Preferences > Keyboard > Keyboard Shortcuts > LaunchPad & Dock. Double click on the current shortcut or blank space where it would be (it'll outline in blue) and then hit F4 to set. I've currently got mine set to F10.

Here's a screenshot:

http://img849.imageshack.us/img849/7227/screenshot20110819at613.png

Poke around in Keyboard Shortcuts as it's really powerful.

BullittMustang
Aug 19, 2011, 11:45 PM
Thanks for the reply. That's what I'm saying is my problem. I can enter F5 and use it successfully. It won't let me enter f4.
Any ideas?
Thanks.

QuarterSwede
Aug 19, 2011, 11:46 PM
Thanks for the reply. That's what I'm saying is my problem. I can enter F5 and use it successfully. It won't let me enter f4.
Any ideas?
Thanks.
Is there a conflict (yellow triangle)?

BullittMustang
Aug 20, 2011, 12:31 AM
Is there a conflict (yellow triangle)?

No, I googled it and it seems others are having the same issue. It could be something left from Snow Leopard after I upgraded to Lion.
I will call Apple tomorrow and see what they say.
Thanks for trying to help.

whiteonline
Aug 20, 2011, 01:24 AM
This was driving me nuts as well (having something new/expensive not working 100%).

Anyway, I found the answer on another forum which is lost in the browser history.
To fix, type in the terminal:
rm ~/Library/Preferences/com.apple.symbolichotkeys.plist

then reboot; launchpad special key starts working automatically.

BullittMustang
Aug 20, 2011, 09:06 AM
This was driving me nuts as well (having something new/expensive not working 100%).

Anyway, I found the answer on another forum which is lost in the browser history.
To fix, type in the terminal:
rm ~/Library/Preferences/com.apple.symbolichotkeys.plist

then reboot; launchpad special key starts working automatically.

Thanks for the info. Does this remove anything else that is needed? And is it reversible if it doesn't work? I just want to be sure before I mess up anything on my new Mac!
Thanks

BullittMustang
Aug 20, 2011, 04:52 PM
Ok,
I called Apple and after a brief time on hold the awesome tech had a solution for me.
here is is.

open finder
click on go on the top bar
put your cursor over home from the drop down menu
hold down the option button on your keyboard while home is highlighted
click on library as your holding down option
open the preferences folder
find the com.apple.symbolichotkeys.plist file
drag it to the desktop
restart your computer
test the F4 key, if it work drag the file from your desktop to the trash

hope this can help someone else
apple tech support is great!

MBHockey
Aug 20, 2011, 05:40 PM
This was driving me nuts as well (having something new/expensive not working 100%).

Anyway, I found the answer on another forum which is lost in the browser history.
To fix, type in the terminal:
rm ~/Library/Preferences/com.apple.symbolichotkeys.plist

then reboot; launchpad special key starts working automatically.

Ok,
I called Apple and after a brief time on hold the awesome tech had a solution for me.
here is is.

open finder
click on go on the top bar
put your cursor over home from the drop down menu
hold down the option button on your keyboard while home is highlighted
click on library as your holding down option
open the preferences folder
find the com.apple.symbolichotkeys.plist file
drag it to the desktop
restart your computer
test the F4 key, if it work drag the file from your desktop to the trash

hope this can help someone else
apple tech support is great!

that's what the other guy told you to do :)

QuarterSwede
Aug 20, 2011, 05:43 PM
that's what the other guy told you to do.
That's also what he said in the original post. I think he just didn't want to screw anything up by mucking in the library. Good sense honestly. Glad he fixed it.

BullittMustang
Aug 20, 2011, 08:36 PM
that's what the other guy told you to do :)

Yes, it is the same result but a different path to get to the result. I wanted to find the folder and delete the file myself. I couldn't find the folder. It is a little tricky to find. I guess they don't want you messing around with them.

Thanks for your input though.

jayman99
Sep 22, 2011, 06:51 PM
open finder
click on go on the top bar
put your cursor over home from the drop down menu
hold down the option button on your keyboard while home is highlighted
click on library as your holding down option
open the preferences folder
find the com.apple.symbolichotkeys.plist file
drag it to the desktop
restart your computer
test the F4 key, if it work drag the file from your desktop to the trash

I followed these instructions and now the Launchpad shortcut key is working perfectly! Thanks to everyone here.

BullittMustang
Sep 22, 2011, 11:44 PM
Glad it worked for you!

ac3320
Sep 30, 2011, 08:30 AM
Glad it worked for you!

it doesn't work for me, or for some other users here :( boo Lion boo!

/\/\4551\/3
Sep 30, 2011, 08:44 PM
Ok,
I called Apple and after a brief time on hold the awesome tech had a solution for me.
here is is.

open finder
click on go on the top bar
put your cursor over home from the drop down menu
hold down the option button on your keyboard while home is highlighted
click on library as your holding down option
open the preferences folder
find the com.apple.symbolichotkeys.plist file
drag it to the desktop
restart your computer
test the F4 key, if it work drag the file from your desktop to the trash

hope this can help someone else
apple tech support is great!

Thanks for this, I've been searching for a while to find the solution to this! Wish it popped up easier in google, oh well.

New wired keyboard launchpad key not working lion

musycsmk
Jul 5, 2012, 09:51 PM
Well... The newest keyboard doesn't work with this solution.. ANYONE?!?!? HELP :(