PDA

View Full Version : Apple TV 2 won´t stream .m4v files from itunes




mortillion
Aug 20, 2011, 02:12 AM
Hi!

I hope someone can help me with my strange problem. As many of us I upgraded to Lion in recent weeks and that brought XBMC/samba problems. I decided to convert some movies in .m4v with Handbrake. Then I added subtitles with Subler. I got 720p video files with AC3 or AAC 5.1 sound. Just as I wanted. I imported the files in iTunes. Apple TV recognised the files normally and played it. It worked like a charm!!!
But one day ATV2 decided it will not start the stream. I did not upgrade neither ATV2, neither iTunes in the meantime.
I can see the list of files, I can select it, but then - nothing. it does not start to buffer or stream.
I tried to play via AirPlay. iPhone4 plays files normally but when I change the screen to ATV same problem. I can even fast forward or rewind, but when I press play same story again.

Any ideas what is going on here?!?

Many thanks for any solution in advance!



Sedulous
Aug 20, 2011, 08:57 AM
Use subler to change the video profile to "main".

spacepower7
Aug 21, 2011, 01:50 AM
Did you optimize the files in subler?

While I love free open source software, some of the paid apps work faster and are updated more regularly. Less problems too...

AdrianK
Aug 21, 2011, 03:17 AM
Post a mediainfo report on one of the non-working files.

mortillion
Aug 21, 2011, 11:07 PM
I guess there is a problem with Subler. Handbake encoded files work fine, but when I add subtitle it does not... I tried the same with iSubtitle and it works!

Ritsuka
Aug 22, 2011, 01:13 AM
You are using it wrong :P
You should just open the mp4 with the "Open" menu item, and add subtitles/metadata. And then optimize if you want better streaming on the atv.

iSubtitle got its code from Subler, so it's using the exactly same thing...

gavdav
Aug 29, 2011, 05:46 AM
Just got a Netgear 150 wireless router as part of a home fibreoptic broadband upgrade

Since then, issues with the 2 older Apple TV boxes (hard drive ones) and 1 newer Apple TV box (streaming one) with streaming films from the iMac.

On the older Apple TV boxes I can connect to the NetGear home wireless, can see all films on Mac, can select them to play, get choice of Resume Play or Start from Beginning. When I choose either option it puts the time bar across the bottom, starts on 0.00 as you would expect but the duration time at the end is also 0.00. Then the screen goes blank and nothin happens at all. Films stored locally play fine

YouTube plays fine, so I can get on the web from the old apple TV boxes

With the newer Apple TV box I can also connect to My Library, select a film, choose resume or start from beginning. If I press RESUME then the picture appears from where it last played but then the spinning wheel spins and spins and nothing plays even after 20 minutes.

YouTube connects, I can select a clip from most featured or most popular, then the timer bar appears at the bottom. It takes a few minutes but does play

It all worked fine with the previous Router. Also a netgear, but model

Channel is set to Auto, as the old one was

Any ideas??

Cheers ...