PDA

View Full Version : More G5 Graphics woes...




phyrexia
Aug 30, 2011, 11:07 AM
Hi.

Six weeks ago I bought a 7800GT for my powermac. It Is a mac model.

Anyway, when I first recieved it I plugged it ito the 16x pcie slot but did not have the power cable. I managed to get it working by using the 6600LE on one monitor and the 7800GT on another. I kept getting graphical errors on the monitor attached to the 7800, which I realized were due to lack of power to the card. However the card worked, would display a desktop, etc. Just red artifacting on text and such.

Edit. Ha. This is where I would have typed "So I bought the power cable." had I better proofread my post.

Now I am trying to use the 7800GT alone with one monitor. I have tried many variations of boot order/DVI output but the 7800GT won't allow the system to boot all the way up. I the gray apple screen, the light blue screen, the dark blue screen, and finally the black screen with working mouse pointer.

I have tried a PRAM reset and safe mode to no avail. Tried booting into the Leopard install dvd, same response.

Is there a proper method for doing what I am trying to do? I am going to try to stick the 6600LE back in there and run two monitors again off two video cards and then pull the monitor cable off the 6600. This seemed to get the cards to work before I had the pcie power cable.

Thoughts?



reddrag0n
Aug 30, 2011, 01:38 PM
if you are running the PCI-e G5, and you have the 7800 video card, go on ebay or someplace and get the power adapter to run the card properly. it uses either an 6 or 8 pin PCI-e power connection.

Also, it has been stated in this thread.
Where is the video card power supply connector on the motherboard? (http://forums.macrumors.com/showthread.php?t=1219465)

GyroFX
Sep 1, 2011, 07:15 AM
why are you even running the 7800GT without extra power? That's just asking for trouble. Might as well run your mac with 256MB ram and hope it'll be ok with all the apps.

phyrexia
Sep 2, 2011, 06:30 PM
Well, I feel pretty dumb, but I forgot to mention that I do have the power cable now. Bought it after I posted the other thread. Thanks again for your pictures, reddrag0n.

At any rate, the thing worked better before I had the power cable. Now that it's powered up it won't boot to a desktop as I mentioned earlier.

VanneDC
Sep 2, 2011, 07:59 PM
I am sad to read this post, hope you haven't fried that great card by running it without extra power cable. Not good.
What os and version are u running?
I haven't had that card, but are there drivers for it to install?
Hope you can get this sorted as it's a awesome card.

Cheers
Vanne

GyroFX
Sep 2, 2011, 08:46 PM
so does running the 6600LE card only work as it normally should?

phyrexia
Sep 2, 2011, 10:15 PM
crossposting from apple forums for posterity:

https://discussions.apple.com/message/16078772#16078772

Install the 7800 only, and connect 1 monitor only. Check
Put the 7800 in the 16x PCIe slot. Check
Start.
Results?

power on>

Gray Screen, Apple Logo by itself, then gray status whirlygig pops up. HDD access.
light blue screen. no mouse pointer. indefinite amount of time passes. hdd still active. dark blue screen for brief period. back to light blue screen, with mouse cursor in top left that doesn't move, and second mouse cursor that corresponds to position of mouse. There are some graphical artifacts that move with the second cursor. at this point the machine is up and running - my mbp is backing up to it via time machine as i type. screen sharing connects and presents the same image then disconnects immediately. i can turn the volume up and down with the keyboard.


If unsatisfactory, restart and reset PRAM.
Results?

power button -> apple/option/p/r -> ding>ding>ding> let go of keys
grey screen, apple logo, gray progress indicator. hdd access. light blue screen. no stationary mouse this time, just the artifacted one. otherwise, same results. machine is active, i can view files on it over a network, etc.

If the results are unsatisfactory, restart in Safe Mode.
Results?

power button >shift>gray screen, apple logo, progress indicator. fans start going crazy. fans stop after 1 min or so, still showing progress indicator. reboots, ding. shift still held. back to grey screen. fans going to town. have a feeling this will loop if i keep holding shift. fans off again. reboot...let go of shift eventually out of boredom. boots to light blue screen with artifacty mouse pointer, system running background functions like time machine and volume up/down.

So I do not seem to be able to boot into safe mode successfully.

This is the same machine that did this: http://i1006.photobucket.com/albums/af189/octavetherapy/DSCN0508.jpg
at boot (this is with just a 6600LE, both monitors set to 1080P resolution. Was fixed by manually changing the resolution on one of the monitors) - I got over that because I hardly ever reboot it, and now I have a shiny new MBP 17, but I'd still like this video card to work.

I have read and have been told that I would not damage the 7800 GT by not supplying it with the proper power. It was not in use but was installed into the machine for the last several weeks.

----------

so does running the 6600LE card only work as it normally should?

With one monitor, yes, it works flawlessly. With two, the only problem I ever had with it was this:

http://i1006.photobucket.com/albums/af189/octavetherapy/DSCN0508.jpg

This happened at boot and was corrected by changing one of the monitor's resolutions (and then changing it back to correct res). This was with just the 6600LE installed. The two monitors were both 1080P monitors - it did not have the problem with a 1080 monitor and a lesser display.

GyroFX
Sep 4, 2011, 06:00 AM
maybe your 7800 card is faulty. I've never experienced that with my Quad when i had the 7800GT. I also had an ATI 1900 G5 edition with no problem either. Sounds like a card issue...

phyrexia
Sep 4, 2011, 08:49 PM
update. i cannot boot into safe mode with either graphics card. Apparently this is due to Apple's software RAID0 implementation. Others on the Apple Support forums have experienced this problem with RAID0.

I'm putting on my thinking cap after Breaking Bad and I'm going to see if I can't tackle this problem. I have hope for my 7800 yet. Even though now all it needs to do is work as a slave machine for X-Plane ;)

Nameci
Sep 4, 2011, 08:57 PM
I am also in Apple Software RAID0 on my boot drive, and have just upgraded gfx card to QFX4500. No issues, plug and play and it just works.

phyrexia
Sep 4, 2011, 09:11 PM
I am also in Apple Software RAID0 on my boot drive, and have just upgraded gfx card to QFX4500. No issues, plug and play and it just works.

You can boot into safe mode?

Nameci
Sep 4, 2011, 09:12 PM
Of course, why not?

phyrexia
Sep 4, 2011, 10:15 PM
Of course, why not?

As I said, people on Apple Support Forums have reported they cannot get into safe mode while they're using the software RAID0.

And, as I mentioned, I cannot get into safe mode with a known, good video card OR the new, unknown card.

Hmm...