PDA

View Full Version : Canon scanner/printer issue




brentg33
Sep 6, 2011, 06:50 AM
Hi all,

I have a mid 2011 27" imac running 10.7.1. I recently had to move some things around in my office. In doing so, i unpluged everything, including my Canon MP640 printer/scanner. I do remember being able to scan using this printer wirelessly on 10.6 and 10.7 and as far as i can remember, before the move on 10.7.1. I went to print something yesterday, and i got a communitcation error. No problem, i went to the printer, re-found my network and the printing part went fine. I then wanted to scan a document, but not only is the printer not showing up in preview or image capture, i am not getting the scan tab in system pref under print&scan. I tried downloading the lastest drivers for my printer from Canon.com and still nothing. I was hoping for suggestions.

thanks



starlir
Sep 6, 2011, 07:29 AM
For me, deleting the printer and then adding it back in Print and Scan has always solved this type of problem, in particular I found that when moving to Lion then updating the drivers, then deleting the printer, adding it back in solved any problem with attached Canon printers (MP640 at home and an IRc5870 multifunction copier/printer at work).

brentg33
Sep 6, 2011, 07:50 AM
thanks, i turned off the computer and printer last night in hopes that when i get home some magic happend. I have to check (as it was very late last night) which drivers i installed (can any check and provide a link of which one i should be using) I had deleted and tried reinstalling last night with no success, perhaps the reboot will help

brentg33
Sep 6, 2011, 12:34 PM
BTW, does anyone know how to unistall canon printer/scanner drivers in the event that i installed the incorrect one?

thanks

darster
Sep 6, 2011, 12:54 PM
I have the exact same problem with my canon mp620. I can print just fine, but can no longer scan after upgrading to Lion. I downloaded the new drivers, deleted the printer and re added, but still can't scan. I think it's either a problem with the Canon drivers, or with Lion.

brentg33
Sep 6, 2011, 01:12 PM
Strange thing is darster, i know i scanned stuff while the imac was running 10.7 and i believe 10.7.1. I wonder if that was all still from my Snow Leopard install and when i deleted and re-added the printer last night, now under 10.7.1, it can no longer find the scanner?
very strange. however, glad im not the only one

thanks

darster
Sep 6, 2011, 01:25 PM
I'm starting to think it's either the drivers or Lion. I also have a macbook with Lion installed, and the scan function doesn't work. So now it doesn't work on both my iMac and macbook, both with Lion. Prior to Lion install, no problem.

brentg33
Sep 6, 2011, 01:36 PM
Darster,

when i get home today, i'll do a test with my older MBP. It too has 10.7.1 installed, but i havent removed to canon in system prefs since snow leopard. I'll see if the scan preferences are still there and delete and re-add to see if they come back after re-add. I'll let you know. Have you contacted Apple or Canon about this?

thanks

brentg33
Sep 6, 2011, 04:32 PM
Hey Darster,

So my MBP running 10.7.1 had the printer and scanner in the system prefs. i deleted and try to re-add, and can not add a scanner....so it must have been left over from SL. on the phone with Apple now.

darster
Sep 6, 2011, 04:45 PM
Hope Apple or Canon resolve this. Good luck

darster
Sep 6, 2011, 05:32 PM
I manually deleted the Canon directory from Library/Printers, then downloaded the new drivers for Lion from Canon, set it all back up, and still unable to scan. Only able to print.

brentg33
Sep 6, 2011, 06:01 PM
darster,

Apple couldn't really help, however, canon made me install their software which while not as easy to use as image capture or preview. It does allow me to scan over the network

darster
Sep 6, 2011, 06:23 PM
darster,

Apple couldn't really help, however, canon made me install their software which while not as easy to use as image capture or preview. It does allow me to scan over the network

What software is it?

brentg33
Sep 6, 2011, 09:17 PM
he had me install the 2nd and 3rd drivers and the MP Navigator under software

http://usa.canon.com/cusa/support/consumer/printers_multifunction/pixma_mp_series/pixma_mp640#DriversAndSoftware

darster
Sep 6, 2011, 10:28 PM
Thanks for the info. I tried doing that too, but still no scan. I have the 620, so perhaps there is an issue with that printer or drivers. So at least I know it is not Lion, since you were able to resolve by updating the drivers.