PDA

View Full Version : Incredibly Laggy OS X 10.7.1




mad cow disease
Sep 12, 2011, 10:29 PM
I recently upgraded from 10.6 -> 10.7. First thing I noticed, incredibly laggy system; I figured maybe it was since I hadn't done a clean format in about 3 years, so I went ahead and did an "old-school" format. Clean install from a 10.7 DVD I made.

The problem? Incredible lag. Whereas previously i could multitask with no problem, now if I have a YouTube video running in one frame of Firefox the other frames become dog slow loading and the video drops to <15 fps. Forget about flash video full-screen, which was previously no issue on this computer. Opening "folders" in Mission Control is laggy and choppy - overall everything seems to have slowed to a crawl. Multitasking is almost impossible without getting the beach ball to some extent between opening programs.

I am running a late 2008 2.4 GHz Macbook Pro with the RAM maxed (4 GB), so the system is far from old or underpowered (my opinion). It's bad enough that I am contemplating going back to Snow Leopard this weekend and doing another format. Any suggestions?

Edit: I should mention that the problem does not appear to be isolated to Firefox: Safari has the same issue with full-screen Flash video. Choppy and unwatchable.



killerrobot
Sep 12, 2011, 10:48 PM
Lion has it's share of problems...although yours seem on the extreme end if you're beachballing that much. You can try the standard resetting the PRAM and SMC and pray for the best or downgrade to SL until the next updates come out. :o

mad cow disease
Sep 13, 2011, 07:35 PM
Jeez, the old PRAM trick...haven't done that since the days of System (yes, system) 7.5. Well, I did do it and it seemed to help. I can now watch full-screen flash at the regular framerate.

Multitasking is still a different story...I may pop a 4 GB RAM chip in this thing and see if that does the trick.

Thanks.