PDA

View Full Version : iMac G3 Power Problem




RAZRVE20
Sep 13, 2011, 03:33 PM
Used to the iMac would have to be unplugged for a while before it would turn on. It was unplugged all day today and when i went to turn it on it came on for a second and then turned back off and there was some sort of sound through the speakers. I unplugged and let it sit and then plugged back in and it kept doing that. What do i do? I want to use this thing. lol



ThunderSnake
Sep 13, 2011, 06:31 PM
Used to the iMac would have to be unplugged for a while before it would turn on. It was unplugged all day today and when i went to turn it on it came on for a second and then turned back off and there was some sort of sound through the speakers. I unplugged and let it sit and then plugged back in and it kept doing that. What do i do? I want to use this thing. lol

Does it power on with an external monitor hooked up?

You can try zapping your PRAM and resetting the CUDA, but sadly this sounds like a failing flyback transformer. It's the death knell of these early iMacs. The problem will worsen until the machine is no longer able to pass POST. Sorry for the bad news and I certainly hope I'm wrong.

RAZRVE20
Sep 15, 2011, 03:53 PM
Does it power on with an external monitor hooked up?

You can try zapping your PRAM and resetting the CUDA, but sadly this sounds like a failing flyback transformer. It's the death knell of these early iMacs. The problem will worsen until the machine is no longer able to pass POST. Sorry for the bad news and I certainly hope I'm wrong.

i got it working again and like i had a cd in the cd drive and it would spin and then the computer would shut down and i disconnected the dvd drive and now it works.... too bad i will never get my usher back :(

California
Sep 18, 2011, 02:56 AM
iMac G3 had bad power cords a lot.

Make sure your cord is okay. Standard cord, try swapping with another machine.