PDA

View Full Version : Macbook Air and Network issues




scottkennedy
Sep 19, 2011, 03:27 PM
My Macbook Air has recently started this thing where it will not connect to my wireless network at home. Not only will it sporadically connect, sometimes, it will just stop in the middle of something and kick me off the network. I have tried resetting my modem and wireless router several times, only to get just a few moments of uninterrupted time online. Anyone have any advice on this? My iMac does not seem to encounter such problems, and it is on a wireless connection as well.

Thanks,
Scott



KPOM
Sep 19, 2011, 03:30 PM
Have you installed the recent EFI update? This supposedly addresses some Wi-Fi issues. There may be others that (hopefully) are addressed in the next update to OS X 10.7. Lion and the new MacBook Airs have had some Wi-Fi bugs. That said, yours seem pretty severe, so if the software fixes don't work, take it in to be tested to make sure you don't have a faulty Wi-Fi card.

scottkennedy
Sep 19, 2011, 04:10 PM
Thanks for the feedback. I tried to download the EFI update, but I am not running lion on my MBA. Should I try to upgrade to that first?

KPOM
Sep 19, 2011, 04:17 PM
The EFI update is just for the 2011 MacBook Airs. Lion brought some bugs of its own to Wi-Fi connections. I didn't realize you were speaking about one of the older Airs. Have you tried removing the network from Network Preferences and re-establishing the connection? That sometimes helps.

It sounds like you might have a hardware problem, though. Perhaps try running the diagnostics (reboot and hold down the D key), or if that turns up nothing, seeing if the Genius Bar can run some tests.

Kornelis
Sep 19, 2011, 05:18 PM
I also have WIFI problems with my 2010 Air 11", mostly after I installed Lion on it. I had problems with (not) connecting to my ADSL modem (Fritz 7340). After I changed the modem from the 5 GHz band to 2.4 GHz band my Air didn't have any problems connecting anymore and the connection itself is stable. My iMac was networking fine on the 5 GHz band and the connection was faster connecting to my NAS because of less interference. Luckily most public WIFI hotspots are not using the 5 GHz band.

Also in other places I have sometimes problems connecting. It helps when I first switch off WIFI and then switch it on again.

Spendrup
Sep 20, 2011, 07:22 AM
My brand new MBA has the same problem, installing all the upgrades did not change anything, actually it's pretty much useless. Some people claim an incompatibility with some routers which I find totally annoying. I mean take any other computer running on Windows and you'll hardly hear about such problems while Apple keeps having bugs with their products especially about something so common nowadays: WiFi
I was told to only use an Apple Express to be sure to keep a good connection?! right, so what do I do when traveling and willing to work in a hotel room?
I've searched on internet and it seems to be a common issue with the MBA and even some MBP. The Apple store said I should bring it back for investigation which I will but to whether be reimbursed or get a new one...as I told them I keep having problems with absolutely all Apple products (iMac, iPhone, MBA) but the iPods or iPad...which is a shame as the MBA is such an amazing toy, powerful, design and not so expensive despite what many people say...however not reliable.

madridista59
Sep 20, 2011, 10:55 PM
oh sweet! so it's not just me with this issue. i have a 13" from feb 2011 and i get this same problem with the wifi cutting in and out. my 2006 white macbook and everything else from appletv to my iphone and ipad never have such an issue.

it's weird that when i'm on the air and the wifi cuts out, that it causes everything else in the house to go offline too. say, i'm watching netflix on my appletv and browsing macrumors on the air. once the wifi goes out on the air, a few minutes later my netflix stream ends.

i haven't upgraded to lion yet on the air either. what's this EFI update? how can i look into that?

tom vilsack
Sep 21, 2011, 12:41 AM
everyone try this...

-system preferences
-network
-airport,advance
-dns
- + 4.2.2.1
- + 4.2.2.2
-ok
-apply

note: the dns numbers i gave are verizons...you could also try your own isp dns server numbers,or googles,or open dns numbers ect ect

macneubie
Sep 21, 2011, 01:27 AM
before u start troubleshooting on the MBA, can you verify if the 2.4GHz wifi channel in use is clean and not interfered by your neighbours?

do a scan of the wifi channels around you with windows netstumbler or equivalent and see if your neighbours are using the same channel as u.

same channels cause mutual interference to ALL wireless clients. try assigning a cleaner wifi channel and see if it helps.

if your wireless AP is dual-band type, try getting your MBA to connect at 5GHz and see if the problem goes away.

LordJim
Sep 21, 2011, 09:38 AM
I'm having the same problem, and I have the EFI Update.

mfr1340
Sep 21, 2011, 09:52 AM
My Macbook Air has recently started this thing where it will not connect to my wireless network at home. Not only will it sporadically connect, sometimes, it will just stop in the middle of something and kick me off the network. I have tried resetting my modem and wireless router several times, only to get just a few moments of uninterrupted time online. Anyone have any advice on this? My iMac does not seem to encounter such problems, and it is on a wireless connection as well.

Thanks,
Scott

my new 17"mbp does the same thing. It has caused all my mac devices to get kicked of the router.

Bach2011
Sep 21, 2011, 10:36 AM
My 2011 13" MBA works fine with g/n 2.4GHz. But to connect with n 5GHz is a bit tricky. I could not connect at first. So I deleted the Keychain Access for that entry. Well, it worked but couple days later, I changed my router from WRT610n (DD-WRT) to E4200 (Stock). The problem happened again. This time I could not find any entry in Keychain. But I tried to remove all related setup for that profile, rebooted, and connected the laptop from where is very closed to the router in order to get very good signal. This time, I could connect without any problem even I moved the laptop upstair. But the speed is so slow though. So I gave up and switched back to n 2.4GHz.

This thread seems to have good tips though. https://discussions.apple.com/message/16177762#16177762

Devil Dog 21
Sep 30, 2011, 11:46 AM
Having the same issue with my 2011 MBA on my home network and my wife's Sony Vaio works perfectly.

Don't understand what's so difficult about getting the wireless in the MBA right considering it's made vital by the lack of a ethernet port!