PDA

View Full Version : MBA running painfully slow...




duvinclunk
Sep 22, 2011, 08:26 PM
So I've had my MBA for just over a year I believe. It was a month or two before the revised body came out so I could be longer. I have noticed over the last month or so that it has been running painfully slow. Items take forever to open, webpages go white after I click away from them and load slow (internet speeds are very good), any video is chopping, etc. Does anyone have ideas how to 'refresh' it? Should I reimage? Any ideas?

Thanks.



orfeas0
Sep 22, 2011, 08:44 PM
So I've had my MBA for just over a year I believe. It was a month or two before the revised body came out so I could be longer. I have noticed over the last month or so that it has been running painfully slow. Items take forever to open, webpages go white after I click away from them and load slow (internet speeds are very good), any video is chopping, etc. Does anyone have ideas how to 'refresh' it? Should I reimage? Any ideas?

Thanks.

Reset the SMC and VRAM. Instructions are in google.

cluthz
Sep 22, 2011, 08:51 PM
Is your HD very full?
Also repairing permissions and repairing HD can sometimes help things.

duvinclunk
Jul 16, 2012, 09:47 PM
Reset the SMC and VRAM. Instructions are in google.
I do that and it seems to work for a bit and then gets super slow again.
Is your HD very full?
Also repairing permissions and repairing HD can sometimes help things.
HD not very full.

Power Macintosh
Jul 17, 2012, 04:04 AM
So I've had my MBA for just over a year I believe. It was a month or two before the revised body came out so I could be longer. I have noticed over the last month or so that it has been running painfully slow. Items take forever to open, webpages go white after I click away from them and load slow (internet speeds are very good), any video is chopping, etc. Does anyone have ideas how to 'refresh' it? Should I reimage? Any ideas?

Thanks.
You totally changed my mind about buying that 2012 MBA. Just cancelled my order. Oh well.

mikkker007
Jul 17, 2012, 06:23 AM
You totally changed my mind about buying that 2012 MBA. Just cancelled my order. Oh well.

So,you cancelled your order on this report...... hmmmm sound decision....
i have Mid 2012/i5/4gb/64 "BASE' model......HD 2 gb from full........ runs Like a dream....!!!!!

Maybe Oz... Air's, are as fast as our Swimmers (Go Australian 2012 Team )

KPOM
Jul 17, 2012, 06:50 AM
I do that and it seems to work for a bit and then gets super slow again.

HD not very full.

Does your model have a hard drive or an SSD? The SSD was optional in the pre-October 2010 models. The SSDs Apple used back then weren't as good (SSDs in general were not), and they do not support the TRIM operation that keeps modern SSDs running quickly.

If you have an SSD, you might check out macperformanceguide.com. The owner of that site put out software called DiskTester that supposedly can recondition an old SSD. It is $40. I haven't tried it. I was about to order it to recondition my late-2008 MacBook Air, but then ordered a late 2010 instead.

Fernandez21
Jul 17, 2012, 08:22 AM
You should probably just reinstall OSx, thats what I did and my air began running quite a bit smoother (it had been crashing a lot) and running cooler, the fans are no longer blasting all the time.