PDA

View Full Version : tap into extra mA for ShowWX




benjaminbr
Sep 22, 2011, 11:16 PM
I've got a 2010 11" and also a ShowWX pocket projector which can charge off USB power but when I turn the projector on, the port only supplies enough energy to cause the battery to drain slower (from 1 hr on battery to 2.5 hrs w/ USB). According to System Profiler I'm only giving it 500 mA, but I've heard that these ports could supply more than the standard half amp. Does anyone have any experience coaxing more juice from these ports or is that ill-advised?



DustinT
Sep 23, 2011, 07:53 AM
the issues isn't the capacity of the port's output, its the input capacity of the device you are connecting. The USB spec demands that all devices indicate their power draw to the controller. In your case, the projector is only requesting 500 ma so that's all that is being supplied. There's nothing you can do unless you can reprogram the usb controller on the projector to ask for more power. Oh, and reengineer the charging system on the projector actually use that extra power to charge the battery instead of going up in a cloud of magic smoke (http://catb.org/jargon/html/M/magic-smoke.html).

benjaminbr
Sep 23, 2011, 05:18 PM
What made me think that that it might work is that the projector came with a wall charger that supplies 1.6A through the same USB port, so I figured it would try and draw the same from the MBA , hence the computer being responsible for regulating the current. Also, Apple's website says the ports can supply up to 1.1 amps, though only to Apple products.

Schwolop
Jul 28, 2012, 07:10 AM
Sorry to dredge up an old thread, but benjaminbr you're the closest person I've found to a solution to my problem. I have the same macbook air as you, and a showwx+ projector. I've got a mini display port to VGA dongle, and the showwx VGA dock.

I just can't get it to work.

The moment I plug in the projector it turns off. If I then detect displays, the MBA finds it, but it has the wrong resolution and none listed are valid.

Have you managed to get this to work? If so, did you instead go MBA->mini display port->hdmi->projector? I don't have the cables for that, but it's my next shot.