PDA

View Full Version : How to disable "wake from sleep on open" on MBA-2011 - Lion?




Poindexter333
Sep 24, 2011, 04:30 AM
Greetings. Who hasn't opened up their laptop bag to feel it as hot as an oven inside from your laptop waking up? Andy Ihnatko had posted a Terminal tip to disable wake from sleep on open- so a keystroke would be required, avoiding a potential meltdown or drained battery. The command was:
sudo pmset lidwake 0

This worked perfectly all the way through 10.6.7, until Lion, on all my Mac laptops, but no more. I try it and then check status with pmset -g profiles but zippo- the value never changes and of course no effect.

I really want to turn this behavior off- any answers? TIA.
Primarily for the Rev E MBA.
----------------
G4 Cube, IIsi, TiBook 667DVI, MBA Rev A(semi-retired) & E/2011(13"/i5 1.7Ghz/4GB/128SSD Samsung/10.7.1), G5 tower 10.5.8, iPhone 3GS/JB/4.0.1



Poindexter333
Sep 24, 2011, 12:02 PM
Wow...nobody knows at this point?

Night Spring
Sep 24, 2011, 12:07 PM
http://osxdaily.com/2011/04/26/disable-wake-from-sleep-when-opening-the-lid-of-a-macbook-pro/

This is for MacBook pro, but i assume it would also work on the Air.

Poindexter333
Sep 24, 2011, 12:17 PM
http://osxdaily.com/2011/04/26/disable-wake-from-sleep-when-opening-the-lid-of-a-macbook-pro/

This is for MacBook pro, but i assume it would also work on the Air.

Thanks Night Spring, but I saw that article during my research before posting here. It is the same Terminal command I've used before, and referenced in my opening post and unfortunately does not work in Lion.