PDA

View Full Version : 5-10 sec freeze after opening air




askrib
Sep 25, 2011, 01:16 PM
Hey anyone else having a problem when they open there new Air from clam shell sleep and it takes about 5-10 secs for you to be able to move the cursor or the time to change. Its like frozen for 5-10secs before I can use it! Super annoying....anyone else have this? Or anyone know how to fix this....


Thanks!



KPOM
Sep 25, 2011, 01:18 PM
If the lid has been closed for more than an hour, it goes into deep sleep and taxes a few seconds longer to start up. That's how it can stay in standby mode for 30 days.

askrib
Sep 25, 2011, 01:24 PM
If the lid has been closed for more than an hour, it goes into deep sleep and taxes a few seconds longer to start up. That's how it can stay in standby mode for 30 days.

Makes sense. But its not always after an hour in sleep that it freezes. If its been like 15 mins....it still freezes just not as long. Maybe 3 -4 secs before I can move mouse cursor. I thought with the new Air you can open and use immediately because of the flash memory?!

joec1101
Sep 25, 2011, 01:34 PM
It's going into Hibernate Mode which I also find quite annoying.

You can disable and/or check the Hibernate mode with the following commands:


Paste this in a Terminal window:

To change mode:

sudo pmset -a hibernatemode 0

To check mode:

pmset -g | grep hibernatemode


I have mine set to 0 and it wakes instantly now - no wait time at all.

stark4
Sep 25, 2011, 02:17 PM
It's going into Hibernate Mode which I also find quite annoying.

You can disable and/or check the Hibernate mode with the following commands:


Paste this in a Terminal window:

To change mode:

sudo pmset -a hibernatemode 0

To check mode:

pmset -g | grep hibernatemode


I have mine set to 0 and it wakes instantly now - no wait time at all.

but then why would you want to do that? it will kill your battery life. I rather wait 5-10 sec extra

joec1101
Sep 25, 2011, 08:50 PM
but then why would you want to do that? it will kill your battery life. I rather wait 5-10 sec extra

It still goes into SLEEP mode, just not HIBERNATE (aka SAFE SLEEP) mode, so there are no issues unless you're battery is drained very low (below 20% or so)

See this article for a more detailed explanation:

http://www.tuaw.com/2011/08/22/why-hibernate-or-safe-sleep-mode-is-no-longer-necessary-in-os/

Bob Coxner
Sep 25, 2011, 09:34 PM
It still goes into SLEEP mode, just not HIBERNATE (aka SAFE SLEEP) mode, so there are no issues unless you're battery is drained very low (below 20% or so)

See this article for a more detailed explanation:

http://www.tuaw.com/2011/08/22/why-hibernate-or-safe-sleep-mode-is-no-longer-necessary-in-os/

What are the issues if your battery is below 20%?

KPOM
Sep 25, 2011, 10:12 PM
What are the issues if your battery is below 20%?

I think the main thing is that normally, a "regular" Mac notebook eventually goes into Deep Sleep when the battery gets below 20% to prevent loss of program information. The Air goes into that mode more quickly, so if you disable it, the battery might completely drain.

echo.park
Sep 26, 2011, 03:16 AM
I recommend to wait for 10.7.2.

Constantine1337
Sep 26, 2011, 07:38 AM
I recommend to wait for 10.7.2.

No need, its the same on 10.7.2

echo.park
Sep 26, 2011, 08:16 AM
No need, its the same on 10.7.2

Alright then... I did set hibernate to 0 just to try it out. Standard is 3, so I can set it back to 'normal' any time in the future, right?

KPOM
Sep 26, 2011, 08:46 AM
Alright then... I did set hibernate to 0 just to try it out. Standard is 3, so I can set it back to 'normal' any time in the future, right?

Yes, that works.

echo.park
Sep 26, 2011, 11:14 AM
I set hibernate mode at 3 and the deep sleep timer at 10 hours.

sudo pmset -a hibernatemode 3
sudo pmset -a standbydelay 36000 (seconds, 60x60x10 for 10 hours)

So I get the 'normal' delay when waking up and the 'much longer' delay almost never due to the 10 hour timer. Still not instant, but better this way.