PDA

View Full Version : MBA 11" i7 VS stuttering html5 on Youtube




Kann
Sep 29, 2011, 02:55 AM
Hi guys,

I just got the new i7 MBA 2011. Don't wanna install flash, now I change my setting on youtube to use only html5 videos (http://www.youtube.com/html5). However, I am not sure if this is because Youtube's html5 beta or my new MBA, but the html5 video on youtube takes much longer time to load compared to flash version. System tends to hiccup freeze for at least 5-10 seconds before Safari would start loading the video. There are times that i got fractions of the video instead of its full length (the video progress bar showed 0:24 instead of 3:xx).

This is weird. The i7 on my MBA seems to be powerful enough. I can play 1080p video easily on quicktime or VLC without problem.

Is this the problem with html5 or OS Lion? Anyone experienced this issue?

----------

My temporarily solution is to use Chrome just to watch Youtube since the browser does already have flash embedded in itself. Do you think that this solution is practical for MBA users who doesn't want to install flash. Just installing Chrome doesn't mean that flash will be installed into MBA system or whatsoever right? Is there any other way around?



Funkymonk
Sep 29, 2011, 03:04 AM
Has to be YouTube. YouTube has been super buggy on all my devices (apple, windows, and Android) lately.

Bernard SG
Sep 29, 2011, 03:12 AM
Agree with Funkymonk, Youtube seems to be having issues. Maybe routing or something like that.

Personally, I have flash installed but I also use click2flash (and AdBlock!) so flash gets loaded only if I really want it to and doesn't suck RAM and CPU charge unnecessarily.

alecgold
Sep 29, 2011, 03:45 AM
I had it the same. Went ok (not great) when it was a small window, went good in flash full screen and was completely unwatchable in full screen size. Didn't matter if it was on the Thunderbolt display or on the 11" itself.
When I downloaded the whole movie (some 100Mb for 3 or 4 minutes) it played perfect. Must be something on youtube as I haven't seen it on other websites either.

Bye Bye Baby
Sep 29, 2011, 11:55 AM
Same problem.

Flash sucks.

YouTube blows.

Aras87
Sep 29, 2011, 12:33 PM
unfortunately I have the same problem. HTML-5 sucks big time in my opinion, especially on youtube. Flash doen't work that great on Mac as well, battery life suffers big time. As a recent mac switcher, I really miss win 7 sometimes.

Daveoc64
Sep 29, 2011, 12:34 PM
Same problem.

Flash sucks.

YouTube blows.
Wow. Did you even read the post?

Brandon0448
Sep 29, 2011, 02:42 PM
Same problem.

Flash sucks.

YouTube blows.

No Macs suck at running Flash, but its still better then Html5. Flash runs absolutely amazing on all my Windows machines.

xraydoc
Sep 29, 2011, 10:38 PM
While there are downsides, I've found changing my DNS server settings on my Mac to point to Google's (8.8.8.8, 8.8.4.4) really improves YouTube's performance on Flash and HTML5 video.

Bye Bye Baby
Oct 4, 2011, 03:33 PM
Wow. Did you even read the post?

Did you?

----------

No Macs suck at running Flash, but its still better then Html5. Flash runs absolutely amazing on all my Windows machines.

I think you have it the wrong way round.

You don't build a computer to run flash, you build flash to run on the computer. Flash sucks on os x.

cleric
Oct 4, 2011, 03:49 PM
YouTube HTML5 is buggy, just use flash.

Daveoc64
Oct 5, 2011, 04:06 PM
Did you?

Nobody mentioned problems with Flash - only you.

RobQuads
Oct 6, 2011, 04:53 AM
See - http://forums.macrumors.com/showthread.php?t=1238925 looks like the latest flash is making HTML5 look not so good.

Bye Bye Baby
Oct 8, 2011, 03:16 PM
Nobody mentioned problems with Flash - only you.

You're kidding? Flash on Mac has never been problematic?

Daveoc64
Oct 8, 2011, 04:34 PM
You're kidding? Flash on Mac has never been problematic?

I was talking about this thread.

There are threads about cars, religion and TV shows on these forums, yet none of those are relevant to this thread.