PDA

View Full Version : Can't trash a file?




VegasMac
May 4, 2005, 12:55 AM
Hello, so for some reason my windows media player didn't work so i redownloaded, and now it works fine, but the old folder is still on my powerbook G4, for some reason when i go to delete it, it says that it's locked how do I unlock it and delete is there a simple way?



840quadra
May 4, 2005, 01:00 AM
Right click (or Control I) get info on the locked file.

After you are in the Get information window, uncheck the "locked" option in the main Get info window.

Benjamin
May 4, 2005, 01:02 AM
or.. hold down option when emptying the trash.

VegasMac
May 4, 2005, 01:46 AM
The problem is I already tried all that and nothing keeps saying it's locked, and there's no even a check mark next to the lock under get info. Now what?

Benjamin
May 4, 2005, 01:48 AM
what are the permissions for the file(s)? are they owned by you or the system.

840quadra
May 4, 2005, 01:50 AM
what are the permissions for the file(s)? are they owned by you or the system.

Also, is there an active process related to this program that you are trying to delete?

VegasMac
May 4, 2005, 02:38 AM
No there shouldnt be anything running, and i went to disk utility and repaired permissions, I'm guessing there microsoft permissions, and still nothing, i've been looking everywhere, I did find that theres a bug in WMP, something about when deleting it creates another file. I don't know this is pretty new to me I can't believe I can't just delet an old file?

VegasMac
May 4, 2005, 02:46 AM
Ok sorry learning as i'm going, so the permissions are set to my computer. Something is locked and i cant get to it.?

Sedulous
May 4, 2005, 02:51 AM
I would think that the file is being used by something. This has happened to me: A file isn't locked, permissions are correct, but won't delete. The "cure all" solution was to restart and delete.

Benjamin
May 4, 2005, 03:01 AM
I have to agree with the above, restart and try.

VegasMac
May 4, 2005, 03:44 PM
I'll see whats up when i get home. Thanks guys.

Claudia
May 5, 2005, 08:07 AM
I'll see whats up when i get home. Thanks guys.

This happened to me too! and i am SO mad at microsoft because they admit to doing this on purpose! Anyway, the trick is to follow the directions that the other people have given you BUT when you delete you must chose "trash" instead of "Secure trash." I know when this happened to me ( i found another thread in this community about it) everyone was telling me that they swore by this method. I kept re-trying and it took me about 2-3 hours of retrying and then finally! after doing the same thing over and over it finally went away. I wish you the best of luck!

VegasMac
May 6, 2005, 12:47 PM
Wow sweet well thank you so much.

monkoverboard
May 7, 2005, 01:24 AM
I think i sent you this email, but just to be sure

I had the same problem, I don't know if you have solved it by now, but this what worked for me:

this is frm the following article: http://docs.info.apple.com/article.html?artnum=106272%20:)

Advanced tip about deleting locked files

If there are several locked files in the Trash, you can unlock them all at the same time at the command line. Follow these steps:

1 Open Terminal. It's located in /Applications/Utilities.

Type: chflags -R nouchg
Note: Type one space (not pictured) after nouchg in the line above, so that it ends in "nouchg ". Do not press Return yet.

2 Double-click the Trash icon in the Dock to reveal the contents of the Trash. If necessary, arrange the Finder window so that a portion of the Terminal window is still visible.
3 Press the Command-A key combination to select all files in the Trash.
4 Drag the files from the Trash to the Terminal window.
Note: This automatically enters the pathname for each file. This eliminates the need to individually empty multiple Trash directories, particularly when multiple disks or volumes are present.

5 Press Return. No special text message will be shown indicating that the command was successful.
6 Empty the Trash.

If the Trash does not empty or if you see a message in Terminal that says "usage: chflags [-R [-H | -L | -P]] flags file..." you most likely did not type the text in step 2 as indicated or did not leave a space. Repeat the steps if this happens.
--------------------------------------------------------

like I said, I had the exact same problem, & this worked the 1st time