PDA

View Full Version : The iPhone could not be restored. This device isnt eligible for the requested build.




bbode0
Oct 12, 2011, 01:22 PM
Anyone else getting this error message? I did everything it told me to do on Apple's website if you got this message, and I'm still getting it.



RayK
Oct 12, 2011, 01:24 PM
Anyone else getting this error message? I did everything it told me to do on Apple's website if you got this message, and I'm still getting it.

DFU restore maybe?

http://support.apple.com/kb/ht1808

dr.devious
Oct 12, 2011, 01:25 PM
I am getting this also on my iPad and iPhone...very frustrating. Tried DFU without success

bbode0
Oct 12, 2011, 01:26 PM
Also tried DFU with no luck

singhjeet29
Oct 12, 2011, 01:28 PM
I got the error message, and then I remembered I had altered the host file in the /etc/ folder on the mac when I jail broke the device and removed the Apple server from list and the update finally went through.

Hope that potentially helps.

bbode0
Oct 12, 2011, 01:32 PM
I've never had mine jailbroken or messed with any of the files. Very frustrating

climber20
Oct 12, 2011, 01:35 PM
you do have the newest version of iTunes right? otherwise, it won't work.

bbode0
Oct 12, 2011, 01:39 PM
Yes, updated to 10.5 yesterday.

billy123
Oct 12, 2011, 01:44 PM
Getting this also! VERY annoying! tried the iFix it thing with editing the host file!
Still nothing ........

guyt
Oct 12, 2011, 01:49 PM
Getting this also on my iPad, 100% legitimate :(

tm.chen
Oct 12, 2011, 01:52 PM
going to restore my phone and update again. this is seriously pissing me off

bbode0
Oct 12, 2011, 02:03 PM
Same here, I've tried everything and cant seem to get it to work.

stridemat
Oct 12, 2011, 02:10 PM
Backup you phone. Click Restore instead of Update. Then restore from you back up.

eastercat
Oct 12, 2011, 02:12 PM
Is your host file point to the correct server? I jb, so mine is pointed to cydia. Even if you don't jb, it still may be pointed incorrectly.
After I corrected in tiny umbrella, it installed fine.

Frio7
Oct 12, 2011, 02:12 PM
Backup you phone. Click Restore instead of Update. Then restore from you back up.

what will this do ?

mluman83
Oct 12, 2011, 02:13 PM
Well I just found out a freind of mine downloaded 10.5 beta itunes on my computer at some point a while ago. Not sure why he did this or where he got it from as he is not a developer. But I have downloaded the new 10.5 itunes and deleted the beta. I am not a dev. I am trying to update my iphone to ios 5 and it says "phone not eligible for requested build".

I dont know what to do to fix this. I have a feeling that by me using that downloaded beta itunes that it has messed something up.

Please help!

bbode0
Oct 12, 2011, 02:14 PM
Backup you phone. Click Restore instead of Update. Then restore from you back up.

Tried this and still getting the same message.

J-Bone
Oct 12, 2011, 02:16 PM
Is your host file point to the correct server? I jb, so mine is pointed to cydia. Even if you don't jb, it still may be pointed incorrectly.
After I corrected in tiny umbrella, it installed fine.

How do I make sure my host file is correct?? I'm not sure what to do

seble
Oct 12, 2011, 02:20 PM
Can anyone help me? I upgraded iTunes and my iPhone to os 5.0 and I'm at the stage of recovering from my backup, except it wants a password, and I know what I'm typing is correct, but it won't have it! :(

meder87
Oct 12, 2011, 02:21 PM
Is your host file point to the correct server? I jb, so mine is pointed to cydia. Even if you don't jb, it still may be pointed incorrectly.
After I corrected in tiny umbrella, it installed fine.

How do you correct in tiny umbrella?

M-5
Oct 12, 2011, 02:29 PM
I have the same problem with my iPhone when trying to update. Mine is jailbroken however, and it won't let me restore.

I already checked off the box in TinyUmbrella that it says I must do to perform a clean restore, but still no luck.

bbode0
Oct 12, 2011, 02:33 PM
Is your host file point to the correct server? I jb, so mine is pointed to cydia. Even if you don't jb, it still may be pointed incorrectly.
After I corrected in tiny umbrella, it installed fine.

Im confused, is there a way to update through tiny umbrella rather than iTunes?

tm.chen
Oct 12, 2011, 02:35 PM
http://lastplaceonthe.net/fix-device-isnt-eligible-requested-build/

Hope this helps for some of you. I am getting internal error after correcting the file.

millserd
Oct 12, 2011, 02:52 PM
Open hosts file, delete any apple entries. Save file. Restart itunes. Restore.

mluman83
Oct 12, 2011, 02:54 PM
I tried changing the host file and still getting same error! I changed host file by following the istructions by adding a "space then #"

I'm loosing my s#*@!

millserd
Oct 12, 2011, 02:59 PM
I tried changing the host file and still getting same error! I changed host file by following the istructions by adding a "space then #"

I'm loosing my s#*@!

Completely removing the apple entries (backup hosts file first) and restarting itunes will allow you to restore ios5.

mluman83
Oct 12, 2011, 03:02 PM
Completely removing the apple entries (backup hosts file first) and restarting itunes will allow you to restore ios5.

You mean I should delete the last line of code completely then save?

eastercat
Oct 12, 2011, 03:04 PM
No. It points your host file in the correct direction, so you can upgrade. I can never remember how to edit it manually, so I use tiny umbrella. TU also saves your blobs, to help you downgrade your ios.
Go to the advanced tab to correct any possible misdirection of the host file.
Im confused, is there a way to update through tiny umbrella rather than iTunes?

mluman83
Oct 12, 2011, 03:07 PM
It seems to be working now!

I followed the instructions via the following video.

It did not work at first. So I went back to the hosts folder and saved it again."text edit / file / save" then put it back into "hosts". Somehow that did the trick!

Video - http://www.youtube.com/watch?v=uL_IWgJ7VNM&list=FLjV9D-rCe5IZf9bWxxKM16g&index=1

Again... this did not work the first time. I went back and saved it a second time and it worked.

J-Bone
Oct 12, 2011, 03:24 PM
It seems to be working now!

I followed the instructions via the following video.

It did not work at first. So I went back to the hosts folder and saved it again."text edit / file / save" then put it back into "hosts". Somehow that did the trick!

Video - http://www.youtube.com/watch?v=uL_IWgJ7VNM&list=FLjV9D-rCe5IZf9bWxxKM16g&index=1

Again... this did not work the first time. I went back and saved it a second time and it worked.

Dude it worked like a charm! THANK YOU A BAZILLION TIMES!!!!

Drag'nGT
Oct 12, 2011, 03:30 PM
Well this is the damnedest thing. Jailbroken iPad -> iOS5 = No problem, worked first time. Jailbroken iPhone -> iOS5 = :( :mad:

M-5
Oct 12, 2011, 03:35 PM
I've gone to the /private/etc/ folder on my mac, and I've dragged the host file onto my desktop, replaced the line with the gs.apple.com with #

But when I try to drag the host file on my desktop into the folder to replace it, it won't let me because it says the host file is in use. I've tried restarting my mac and iPhone several times, and nothing seems to work.

J-Bone
Oct 12, 2011, 03:38 PM
I've gone to the /private/etc/ folder on my mac, and I've dragged the host file onto my desktop, replaced the line with the gs.apple.com with #

But when I try to drag the host file on my desktop into the folder to replace it, it won't let me because it says the host file is in use. I've tried restarting my mac and iPhone several times, and nothing seems to work.

Follow the video above it worked for me.

utl768
Oct 12, 2011, 03:38 PM
how do you fix it via tiny umbrella

M-5
Oct 12, 2011, 03:39 PM
Follow the video above it worked for me.

I did, but once I drag the hosts file back into the folder to replace it and "authenticate" I get a pop-up message that says:

"The operation can't be completed because the item 'hosts' is in use."

J-Bone
Oct 12, 2011, 03:41 PM
I did, but once I drag the hosts file back into the folder to replace it and "authenticate" I get a pop-up message that says:

"The operation can't be completed because the item 'hosts' is in use."

delete the original file first then drag fixed file in if that doesn't work restart your computer and try again that's what I did

P.S.

Don't forget you might have to do it twice for it to work I had to.

mluman83
Oct 12, 2011, 03:46 PM
Glad to see this helped out!

M-5
Oct 12, 2011, 03:51 PM
delete the original file first then drag fixed file in if that doesn't work restart your computer and try again that's what I did

P.S.

Don't forget you might have to do it twice for it to work I had to.

It still wouldn't let me replace the file, and I tried shutting my computer and phone off and on several times and trying to restore on iTunes. But for some reason, I tried restoring again and iTunes finally let me.

Not sure exactly what I did right, but my phone is now restoring from backup on iTunes. Seems to be going smoothly so far.

Drag'nGT
Oct 12, 2011, 04:31 PM
It seems to be working now!

I followed the instructions via the following video.

It did not work at first. So I went back to the hosts folder and saved it again."text edit / file / save" then put it back into "hosts". Somehow that did the trick!

Video - http://www.youtube.com/watch?v=uL_IWgJ7VNM&list=FLjV9D-rCe5IZf9bWxxKM16g&index=1

Again... this did not work the first time. I went back and saved it a second time and it worked.

I don't have that line of code from the video in my "hosts" file.

Qoo
Oct 12, 2011, 10:08 PM
finally upgrade from iOS 5GM to official iOS 5 :D

fgarvin
Oct 12, 2011, 10:56 PM
Dang... This stinks!!!

I have tried all the above... for 12 hours now...

Still get the same error.

Please help...

Got Macbook Pro, Lastest iTunes, iPhone 4 that is jailbroken, and ios 5 downloaded.

jordanogrady
Oct 13, 2011, 11:13 AM
It still wouldn't let me replace the file, and I tried shutting my computer and phone off and on several times and trying to restore on iTunes. But for some reason, I tried restoring again and iTunes finally let me.

Not sure exactly what I did right, but my phone is now restoring from backup on iTunes. Seems to be going smoothly so far.

Im getting this same issue! Any news on how to solve this?

jordanogrady
Oct 13, 2011, 12:08 PM
Ok, finally replaced the file, I deleted the original and then put the edited one into place..

Will try yet again and see what happens!

Jordan

adace55
Oct 17, 2011, 10:09 PM
hey ive been looking on all sorts of forums and solutions and none seem to work for me... also im terrible with computers.


-i have the iphone 4 with version 4.2.6 (8E200)
-i have a macbook pro
-i have the latest version of itunes adn by computer software is up to date
-i have restarted my computer
-i looked to see if in that /etc/ thing for that apple. something in the host file and its not even listed in there

please help me im going crazy. any ideas would be amazing. thanks!