PDA

View Full Version : iPhone will not let me restore




awcomix
Oct 12, 2011, 03:37 PM
I got impatient and downloaded a beta version of iOS 5 yesterday. Every thing was going fine until I got to a screen that said,
'this device is not registered as part of iPhone developer program...'

From this point I tried to restore, and got a message the software was not available. I have tried again today now that it has officially released and at first it look like it downloaded the new ios5. However I still get the same developer warning screen. and can't go any further.

Is there any way to erase this previous developer settings and start fresh with witha full restore? Could I jailbreak it, wipe everything and then restore?

I have an iphone 4 16gig, and being in Australia I'm 99% it's GSM

See screen grabs for exact error messages



grapes911
Oct 12, 2011, 03:39 PM
Manually download the correct IPSW for your device and then manually install it. The info is in the below link.
http://forums.macrumors.com/showthread.php?t=1247406


And stay away from betas in the future. ;)

awcomix
Oct 12, 2011, 11:48 PM
Thanks Grapes! This worked a treat! Very relieved!

I will definitely not be doing anything like this in future!!

;)