PDA

View Full Version : Duplicate Email on iPhone




lorax3
Oct 13, 2011, 12:08 AM
Setup iCloud on 10.7.2 and iOS5, but am now getting two emails sent to my phone when email it sent to my iPhone

Not sure how to fix this. I stopped iCloud syncing then both the MobileMe and iCloud email boxes went away. In Mail settings on iPhone is only shows an "iCloud" account, but in the actual app I see two inboxes. iCloud and MobileMe. Thoughts?

I would think I just need to delete the MobileMe account and leave the iCloud account, but I see no way to do that. Removing iCloud sync for mail removes both inboxes.



omarrodz
Oct 13, 2011, 03:28 AM
I have the exact same problem. If I turn it off, both email addressees are gone (identical emails - duplicates). Is it a glitch perhaps?

ndgold
Oct 13, 2011, 04:36 AM
I have the identical problem. Two inboxes, and I have to either keep both or see none.

FranzMarc
Oct 13, 2011, 05:31 AM
Same here...turning off either removes both the "iCloud" account in Mail,Calendar etc. and the mail in iCloud. Weird.

lornamac
Oct 13, 2011, 06:07 AM
I had the same problem. Deleted the iCloud account then re-added it with my MobileMe address and problem solved :)

FranzMarc
Oct 13, 2011, 06:18 AM
I had the same problem. Deleted the iCloud account then re-added it with my MobileMe address and problem solved :)

This did indeed fix it, thanks :) Only tried deleting the MobileMe Mail account which didn't work.

ivaldor
Oct 13, 2011, 06:31 AM
I had the same problem. Deleted the iCloud account then re-added it with my MobileMe address and problem solved :)

Yep, this is the solution! It happened in beta version of iOS5 too.

Lothlaurien
Oct 17, 2011, 01:51 PM
When you say delete iCloud account do you mean go into settings and click on iCloud under General and delete click delete account? Or are you deleting your account under the mail settings?

d21mike
Oct 17, 2011, 02:35 PM
I assume you did the www.me.com/move of your MobileMe to iCloud. Then on your iPhone you answered the question to switch over.

After above you need to go into your Mac Settings and you will see iCloud and MobileMe. MobileMe is still there because you may still want to Sync things like iDisk (and other things) which is still good until June 2012. You need to either LOGOUT completely from MobileMe or you need to un-check those things you do not want to Sync. For sure you do not want to continue to have MobileMe Mail, Contacts and Calendar since you did the MOVE to iCloud.