PDA

View Full Version : Help iCloud Duplicating




Daniel97
Oct 13, 2011, 08:33 AM
My calender is appearing on my iphone 2 times?

Every appointment has 2 entries.

If i go into calenders only icloud is selected so there is no reason for all appointments to be duplicated?



cello2456
Oct 13, 2011, 08:37 AM
Me too! It is driving me crazy. I stayed up till 3 in the morning trying to fix it and they are still there. Anyone??

CBX
Oct 13, 2011, 08:44 AM
I had this.

I went to sys prefs and unchecked calendar. Selected 'delete from my mac' wait a few seconds, then re-check calendars and select 'merge'.

If you want to try this I would suggest backing up your data! As I said this worked for me but you may find different.

fifi77
Oct 13, 2011, 08:49 AM
I also had this, but mine was caused by something quite simple. I realised that I had a CalDav account running as well as Calendars turned on in my Exchange account. Despite unchecking the Exchange account in the Calendars app, it kept turning itself back on, so things were appearing twice. I turned Calendars off in my Exchange account and just left the CalDav running and now only see things once.

Daniel97
Oct 13, 2011, 09:30 AM
I had this.

I went to sys prefs and unchecked calendar. Selected 'delete from my mac' wait a few seconds, then re-check calendars and select 'merge'.

If you want to try this I would suggest backing up your data! As I said this worked for me but you may find different.

is that system prefs on your mac?

sorry im a retard i need an idiots guide lol

CBX
Oct 13, 2011, 09:35 AM
is that system prefs on your mac?

sorry im a retard i need an idiots guide lol

Yep, I had duplicates on the mac, so system prefs on the mac.

redperson
Oct 14, 2011, 08:38 AM
I had this.

I went to sys prefs and unchecked calendar. Selected 'delete from my mac' wait a few seconds, then re-check calendars and select 'merge'.

If you want to try this I would suggest backing up your data! As I said this worked for me but you may find different.

I did a similar thing from my iPhone, since that's where the duplicate entries were. I repeat the suggestion to confirm that your data is backed up, on your Mac, for instance, before doing this:

- on the iPhone, go to Settings
- toggle "calendars" OFF
- at the prompt, select "delete from my iPhone"
- at this point ALL your calendar data should be deleted from iPhone
- reboot iPhone
- go back to Settings, toggle calendars ON
- after a few minutes, all the data is back, but without duplicates

I surmise that the original sync during the iCloud activation had a bug or redundancy.

metoo6000
Oct 16, 2011, 02:39 AM
For me, iCloud duplicated ical and contact data on my mac. I deleted data on iCloud and re-sync, but it created third copy on my mac. Really made me crazy. So I turned off the ical and contact sync, and sync via iTunes for now.

hafr
Oct 16, 2011, 06:48 AM
I had duplicates because I synced the calendar with both iTunes and iCloud. I deactivated the calendar sync in iTunes and the duplicates disappeared.

moseleyite
Oct 16, 2011, 09:42 AM
The following is my experience - I'm not saying that this is the problem that you are having but I hope it helps:

I also had what appeared to be a duplication of iCal events until somebody pointed out that, when moving to iCloud, my MobileMe events were copied to iCloud so the apparent duplicates were in fact one entry for MM and one entry for iC.

The solution to this issue, for me, was as follows:

1. Go into iCal preferences.
2. Click on 'Accounts'
3. Select the MobileMe account and de-select the 'Enable this account' option.

My duplicates then disappeared. You can actually delete the MM account if you like but I decided to just untick the option - call me paranoid if you will!

By the way, I didn't have "duplicate" contacts - only calendar events

Ledgem
Oct 16, 2011, 04:10 PM
I had this.

I went to sys prefs and unchecked calendar. Selected 'delete from my mac' wait a few seconds, then re-check calendars and select 'merge'.

If you want to try this I would suggest backing up your data! As I said this worked for me but you may find different.
This fixed it for me, thank you!

McRCN
Oct 16, 2011, 05:28 PM
I did a similar thing from my iPhone, since that's where the duplicate entries were. I repeat the suggestion to confirm that your data is backed up, on your Mac, for instance, before doing this:

- on the iPhone, go to Settings
- toggle "calendars" OFF
- at the prompt, select "delete from my iPhone"
- at this point ALL your calendar data should be deleted from iPhone
- reboot iPhone
- go back to Settings, toggle calendars ON
- after a few minutes, all the data is back, but without duplicates

I surmise that the original sync during the iCloud activation had a bug or redundancy.

Thanks for sharing. It worked perfectly for me too.