PDA

View Full Version : Apple TV2 library update problems.




Praksis
Nov 3, 2011, 05:42 AM
I backed up a couple 100 DVD's i have to my home server.
- All were backed up using the same settings in Handbrake
- All were added to my iTunes correctly
- All show up correctly on iTunes (on my mac)
- Only about half of them show up on my Apple TV2...... :confused:

Tried rebooting the Apple TV, reseting from backed up settings, reseting to factory default settings, all updates are installed (both on the macPro running the iTunes library (using Snow Leopard) and on the Apple TV2) and still movies and TV Series show up correctly on my Mac but not on the Apple TV2... Apparently the only thing that syncs up correctly on the Apple TV2 is music and subscribed podcasts...

Any ideas on what may be causing this problem and a possible fix/solution?

Thanks in advance.



bonestep
Nov 3, 2011, 06:05 AM
Just a couple of questions Praksis; what ios is apple tv running? Has the system always functioned like this or has it changed behaviour?
Cant promise a solution but wondering wether we have a similar problem.

Praksis
Nov 3, 2011, 10:09 AM
Hi bonestep.
Tkz for your reply.

Cannot confirm 100% at the moment (i'm at work) but will do so as soon as i get home in a couple hours, but if i'm not mistaken i believe the Apple TV IOS version is 4.4.2.

The update option on Apple TV says it does not have any new updates to run (ran it last night).

I cannot say exactly when this started, (if it was due to 4.4.1 or 4.4.2), but when i got my Apple TV (fairly recently) it had 4.4.0 build 9A334v on it and everything worked perfectly. Last month i updated it to 4.4.1 but due to work didn't end up using it, so unfortunately i cannot say if that problem started with 4.4.1 or 4.4.2.

This past week when i turned it on i had a message saying if i wanted to download the new version and update it, i came here to MacRumors and read that there were some issues with it on 4.4.1 but that they had been solved in 4.4.2, so i went ahead and updated it.

Now, even some movies and TV shows that i'm 100% sure were there before are gone, and the file structure on the TV shows is all screwed up as well.

Example: i had a "folder" called Chuck season 1 and inside it i had all the season 1 episodes, now i have a folder named Chuck season 1 and instead of having all 13 season 1 episodes inside i only have 4 episodes, 3 more episodes show up outside the "chuck season 1" folder as "chuck season 1 episode 8", "chuck season 1 episode 9" and "chuck season 1 episode 11" and all the other ones are gone. So, out of 13 organized episodes i now have 4 organized files, 3 unorganized files and 6 files that disappeared.

Same happens with other TV episodes, and also some entire series (and movies) are gone (and they were there before, i'm 100% sure of that).

Meanwhile, all is well in iTunes, all folders are organizer correctly, all episodes are inside the correct folders and no TV episodes / entire TV shows / movies are missing... this is just happening on the Apple TV...

(Sorry for the long reply)

bonestep
Nov 3, 2011, 03:48 PM
Thanks for the info Praksis. Looking at feedback on the forums (both here and apple support), it seems as though user experiences are not uniform. I for example have the "there was an error loading this content." warning followed by the invariably useless "try again later." This has not occurred in a regular fashion as initially all ripped content seemed to trigger the warning (all ripped from DVDs I own) now all content is unplayable except 2 of 380 movies and 200 TV shows. Others seem to be stuck on the spinning clock logo as if content is actually loading.
What I am trying to do is narrow down the likely culprits in terms of updates so pressure can be exerted on Apple for another update to cure all the problems.