PDA

View Full Version : I need previois version of Itunes for Mac to sync my iphone 4.3.3(jailbroken)




coskc
Nov 4, 2011, 12:51 PM
my phone is jail broken. firmware 4.3.3 Don't want t lose up. I need a get previous version of iTunes so I won't lose my apps.

thanks



soco
Nov 4, 2011, 12:52 PM
Wasn't there a site called lastversion or something like that?

Bl0ckHe1d
Nov 4, 2011, 02:28 PM
my phone is jail broken. firmware 4.3.3 Don't want t lose up. I need a get previous version of iTunes so I won't lose my apps.

thanks

http://www.hackstor.biz/2010/02/itunes.html

Carlanga
Nov 4, 2011, 07:15 PM
you won't lose your apps by having the latest version of iTunes though...

thelatinist
Nov 4, 2011, 08:05 PM
Where did you get the idea that you will lose your apps if you use the current version of iTunes?