PDA

View Full Version : iBook Sleep Issues Under Tiger




celaurie
May 17, 2005, 06:35 AM
Here's one for you guys to mull over while I get some sleep.

I archive and installed Tiger a few days ago on my G4 iBook 800/256/30GB. Since doing so I have been plagued by;

(i) kernel panics that occur usually when I am typing in an iChat window and,

(ii) when returning to my iBook after a momentary absence I am finding the screen is black but the sleep light is not on. No matter how much movement of the mouse or tapping of the keys I do I get no response. What is weird is that sometimes when this happens I can hear disk activity, but at other times I cannot.

I've repaired the permissions, run all the little doodahs in Cocktail, run disk first aid (no errors) and did the BSD permissions repair thing.

Any suggestions before I go borrow an external HD and wipe the drive clean before going for a clean install?

TIA.

~cel



Eniregnat
May 17, 2005, 08:08 PM
If nobody else can help you with these problems (including Apple), try these links.
A thread on the Tiger 10.1 update (http://forums.macrumors.com/showthread.php?s=&threadid=127084)
Search Apple's documents about the update. (http://docs.info.apple.com/article.html) I don't think it will help with all the problems, but it might.

Give Apple your thoughts and report the problems here/ (http://www.apple.com/macosx/feedback/) Apple has always contacted me when I tell them about bugs.

Your problems don't seem too common. Are you still under warrenty or Apple Care?

At least I can help bump you back to the top.

celaurie
May 18, 2005, 02:23 AM
Hey man, thanks. I did have a cursory search of the TIL, but was unable to turn up any hits, hence why I posted here (as well as to see if if I was missing something obvious) I'll follow your suggestions as the problems persist, even with the 10.4.1 Updater.

I might back everything I have up onto DVDs and go for a clean install. First, I'll need a day off!

(Thanks for the bump back up the listings!)

~cel

Eniregnat
May 18, 2005, 02:29 AM
I might back everything I have up onto DVDs and go for a clean install. First, I'll need a day off!

(Thanks for the bump back up the listings!)

~cel

That's what I needed, a day off. And in the spirt of Office Space, I took a week. Funny, it's impossible to get caught up on things until one has free time, but fill the time and it is no longer free.

Best of skill and luck in life.

Post Script: First time in years, though my boss attempted to tell me I had time off 2 years ago when I was hit by a car while riding my bike (at least we think I was hit by a car, I have spotty memory of the event. That wasn't time off, it was torture. I thought about work every day and then rushed back to work. That was foolish.

celaurie
May 18, 2005, 02:39 AM
That's what I needed, a day off. And in the spirt of Office Space, I took a week. Funny, it's impossible to get caught up on things until one has free time, but fill the time and it is no longer free.

Best of skill and luck in life.

Post Script: First time in years, though my boss attempted to tell me I had time off 2 years ago when I was hit by a car while riding my bike (at least we think I was hit by a car, I have spotty memory of the event. That wasn't time off, it was torture. I thought about work every day and then rushed back to work. That was foolish.

LOL, so you're telling me I need to get hit by a car. Right... If you don't hear from me for a few weeks, you know I've been sucessful! Problem is I wont want to go back!

Tangerine, eh? Finest colour of iMac ever made. ;)

celaurie
May 19, 2005, 07:56 PM
Just to add to this, a friend has just informed me that he is having similar issues with his G5 iMac 1.6/512/80 GB - is anyone else suffering from these problems!?

~cel

slooksterPSV
May 19, 2005, 08:33 PM
Sounds like the problem I had with my Powerbook and Jaguar

Dave Marsh
May 19, 2005, 08:37 PM
The first thing I would try would be to upgrade your iBook to at least 512MB of RAM. In the meantime, I'd suggest turning off/uninstalling any old non-Apple System goodies you may have installed under Panther. Also, Dashboard will consume ~5-7MB of RAM for EACH widget while they are idling, and ~200MB EACH when they're in use. So, if you don't have enough RAM, the system will be paging out to the hard disk, which is MUCH slower. Basically, what I'm telling you is that, while Tiger is great, it consumes a lot of system resources, and system anomalies may be the result while your tasks are accumulating, waiting to be processed. Also, Spotlight automatically indexes in the background whenever you update or move a file, which accounts for its quick response. If you can, I'd simply add a 512MB RAM module, take your iBook to 768MB of RAM, and try it out again. ;)

ChrisFromCanada
May 19, 2005, 08:48 PM
Next time you have the no video problem try turning up the brightness on your display.

HE05
Jul 12, 2005, 10:52 PM
Unfortunately I have noted the same sleep problem as celaurie with my PowerBook G4 (1.25GHz, 1GB RAM). This is similar to a problem I had using Panther, which was fixed in 10.3.8, although it was more random using Panther. With Tiger the problem reoccurred, but is now consistent.

Every time the PB tries to go to sleep (automatically or manually), the screen is blanked, but I think it actually stays running (system fan may come on, and the sleep LED does not pulse like it should). Neither the mouse, touchpad nor the keyboard will allow it to recover from this state. The only option is a forced shutdown / restart via the Power Button.

Unfortunately, updating to 10.4.2 still did not fix the problem. Not having a sleep function on a PowerBook / iBook is VERY annoying!!! I hope Apple will provide a fix soon!

Dave Marsh
Jul 13, 2005, 12:02 AM
Try going into the System Preferences/Energy Saver and moving the Put Display to Sleep slider all the way to the right to Never, then see if the screen blanks out again.

If that doesn't help, go into your /Library/Preferences/SystemConfiguration folder and trash com.apple.PowerManagement.plist. That will restore your Energy Saver Preference Pane to its default settings.